WD discovery desktop app not login


iam facing this issue when i try to login on WD discovery on windows 10

Login Service unavailable

H there,

The same issue here.

On Windows 10 cannot login.

Also on another PC (already logged in) I can’t see shared folders.

Thank you

1 Like

WD Servers / Software have a fault. See other posts re Share Link creation etc over the last 18 hours.

It is VERY IMPORTANT all people with these problems report this to WD directly. They do not act on these Forum posts.

So far WD do not appear to be accepting these problems as a WD issue their end, and treating each reported issue as a User equipment problem.

All Readers. Test your Drive re signing in, creating shares, and downloading from a link in a Browser and if you find a problem REPORT this yourself to WD immediately.

1 Like

Thank you. Now I’m trying to find where and how can I report this issue directly to WD.

1 Like

You need to open a ‘CHAT’ contact.

They will try to take you through a prepared Idiots Guide.

Tell them to view the posts on the Forum in the last 24 hours and they will see people reporting similar issues with creating share links, downloading them from a Browser etc.

The person you will be talking to cannot do anything SO yo must insist they escalate it to their Technicians so tests are carried out on the WD Server / software. Cheers

For me chat is closed, but I managed to open a ticket. Thank you!

Same issue for me. I have submitted a “question”!

1 Like

Same here, one W10 pc logs, the other does not. Android phones can log. Browser can log. Desktop application doesn’t.

I’ve having the same issue i’ve tried to chat with WD support agents serveral times they just keep telling you to restart your computer,disable ani-virus,and update windows !

Any suggestions ?

I’ve received an answer from WD:

In order to isolate the issue, please provide us the following information:

How long have you been facing this issue?
What is the network topology that you are using to connect the drive?
What is the LED status on the front panel (color)?
What is the Operating System version of your computer?
Are you able to log in through Web App (My Cloud.Com) and Mobile App?

Please provide the screenshots of the errors.

Also, please refer to the mentioned link to troubleshoot the issue and share the outcome.
https://support-en.wd.com/app/answers/detail/a_id/6229/kw/Login%20Service%20unavailable

In case that the issue remains after following the article above, please provide us the screenshots of any error message received.

After that I restarted my PC and now WD Discovery is working again. I didn’t check the other PC yet on which I was unable to log in.

Now I checked the other PC. Login is working again. I had to share the shared folder again, but this is working, too. I think, they solved the problem…

It was a problem at their end

Not working AT ALL on MacOS Catalina on My Cloud Home Duo.

24 HOURS OF SHUTDOWN!!!