WD Dashboard doesn't recognize WD internal drives in 3rd party enclosure

I have two WD Gold HDDs installed in the OWC Gemini Thunderbolt 3 enclosure and WD Dashboard doesn’t seem to recognize either of them. Any solutions or is this a common problem with using 3rd party enclosures? Are there any possible workarounds?


What Gold drives do you own?

Search Support | Western Digital

All Hard Drives: Shop Internal, External, Portable HDDs | Western Digital

I have two 14TB Golds. Does that matter as it relates to the dashboard? (I’m hoping not)

Is this what you own?
WD Gold Enterprise Class SATA Hard Drive Up To 22TB | Western Digital
Have you read the information I provided? I don’t own any Gold drives. If the info doesn’t answer your question, then you need to ask Western Digital. Use the link at the bottom of this page. Contact WD

The WD Dashboard is probably looking for the hard drive controller, but when the drives are in the external enclosure it sees the enclosure controller instead.

Computer --> Enclosure --> Drive

Have you tried a direct SATA connection?

Computer --> Drive

I have not tried a direct SATA connection and at this point I believe it’s too late because I’ve already set the two drives as a RAID 0. If I did put them out and direct connect via an SATA connection, I would lose my data, correct? I really just wanted to see if there were any firmware updates for my WD Gold drives and the WD site doesn’t have anything regarding firmware info for the WD Golds.

Unknown, but I wouldn’t risk it.

Hard drive firmware updates are pretty rare, so I wouldn’t worry about it too much, especially if everything is working correctly.

1 Like