WD Dashboard Cannot Run Diagnostic Tests - SN850

I purchased a new SN850 2TB RGB drive and have not been able to get WD Dashboard to run any quick or long diagnostic tests since assembling my motherboard and freshly installing Windows 10 64bit. When I click the diagnostic test button, all it says is “Operation Failed”. Everything else with the drive seems to work fine with chkdsk passing and no Event Viewer errors with WD Dashboard or the device.

Anyone have similar issues with WD Dashboard?

CPU - Ryzen 3900X
Motherboard - ASUS X570 Dark Hero
PSU - Seasonic Focus Gold 1000W
GPU - Gigabyte 2080Ti Aorus Xtreme

This is a known issue on SN850 RGB models and should be resolved in the next release of Dashboard.

I am glad to hear that this is getting identified. My WD support representative has told me they are still trying to recreate this issue, so I was getting worried.

Hi @imaginary_num6er,

I need your help, I have really low write speed when running my 2TB in chipset M.2 slot.
On X570 Dark Hero this is the bottom slot (bottom right next to the sata ports).
Is their any chance you can connect your SN850 on this M.2 slot and do a Atto Disk Benchmark on the drive ?

This would really help me know if my drive has an issue or if my motherboard has an issue:

Thanks, Mat :slight_smile:

Sorry for reviving the thread, I’m experiencing the exact same issue with my SN850 1TB and I couldn’t find any other thread that mentions this.

The drive is performing as it should, It handles any test/benchmark I throw at it very well even the Quick/Extended tests from the old Data Lifeguard Diagnostic tool from WD, but when I try to run the test from Dashboard it wouldn’t even run, goes straight to “Operation Failed”.

Hey @LostLinuxGuy could you provide any source for this please? did WD confirm that this is a bug in Dashboard? This doesn’t seem to be a common issue.

I’ve previously emailed WD support and they just responded to tell me to RMA the drive if it failed the SMART tests which isn’t very helpful as the test wouldn’t even start and I’m not sure if the drive is defective.

After spending weeks waiting for feedback from WD’s engineering team, I decided to submit an RMA in hopes that this will solve the issue or at least eliminate one less variable for the root cause. I believe it took roughly 6 weeks before the WD Support guy recommending an RMA. I never heard back from @LostLinuxGuy or the WD Engineering team directly, but after calling WD they told me the issue may or may not be solved with a WD Dashboard update or a drive replacement. Unlike your issue, other users on a different forum have reported not running into any problems with a 1TB SN850 non-RGB model with a X570 Dark Hero board in diagnostic tests, so your issue might be different.

With RGB, a potential work around I found was to open WD Dashboard, create a new profile, and if that doesn’t work shutting down and manually booting the computer allows me to create a new profile. Rebooting does not work for whatever reason and one does not need to turn the PSU off for this work around to work. Obviously very inconvenient, but it at least allowed me to test RGB settings.

I’ve been updating WD Dashboard with each revision, but as an update I am able to announce that WD Dashboard version released on July 24th 2021 appears to have fixed the issue. Even their change log suggest as such:

  • Fixed firmware update failures on SATA devices found on some AMD chipsets using the Windows inbox driver
  • Resolved numerous issues with Device Self Test related to specific devices and drivers

I guess 8 months late is better than never, since I purchased my drive back in December 2020


I bought my 1TB with heatsink and everything was fine until I ran the gaming mode option. Now none of the information of the disk shows of the screen and I can’t run or monitor anything.

A new bug maybe?

Turns out that the information on the M2 vanished from everywhere. I believe tis happened whern turned on the gaming mode on the Dashboard WD.

I am getting terrible low speeds, I know I wouldn’t have the same results as using a full PCI 4.0 model. But I feel something is terribled wrong since the previous model (750) reached higher number than this.

My rig:

ROG Z590-A Gaming Wifi
Intel 10950k
32Gb DDR4 3200Mhz Kingston Fury
WDBlack 1Tb 850 Heatsink



@RickDaSilva - Check that you are using the NVMe driver in Windows. It looks like you are using that is surfacing the SCSI interface only.

Look at this thread for a similar issue WD 850 & 750 Black Drives - Only 850 Is Showing as a Black Drive in the Software, Am I doing something wrong?.

This can’t entirely be the dashboard software. I think it is a combination of dashboard, drive firmware and possibly faulty drives. WD drives have had major issues all over the B450, B550 and X570 chipset motherboards.
My drive was working and still seems to be working fine. I ran the short diagnostic test and passed 1 SINGLE TIME. I also ran a controller test in BIOS 1 SINGLE TIME.

Now I cannot test the drive at all in BIOS or in Dashboard. I believe it is the firmware chip or controller. Something with testing will fault the firmware or controller chip which can be fixed with software tricks or a BIOS fix. BIOS fix has been done on the SN850 series by MSI. I am taking a bet that timing of commands sent to the drive is key.

When WD support says a BIOS update may or may not fix it and also say replacing the drive may or may not fix it confirms they screwed up.

EDIT: Will also note that I have a Samsung NVME drive that tests fine in BIOS so it is not my BIOS! It should also be noted that was dealing with another issue so my system is barebones with fresh windows 10 that just has Dashboard and Samsung Magician on it besides necessary drivers and Windows updates.

I have many makes and model of SSD products

I am wondering if a motherboard BIOS needs updating