WD Blue 2.5 goes to sleep/spin-down after 20seconds

Hi. My WD10JPVX (WD Blue 2.5) goes to sleep after about 5 seconds of inactivity. I would like to change that setting to 10 minutes at least. This short (5sec) spin-down/sleep, whatever you call it, is not normal, and will certainly cause hdd damage. I found this thread with the same issue and still no answer/fix.
Please help!

Ok. So I found the fix. Thank you so much ceztko. Just read his post, he explains everything. For me 80hex is also much more acceptable. 60hex (default) was way to aggressive. I didn’t mess with wdidle3, only with CrystalDiskInfo. So my setting is this, after 8 seconds the drive parks the head (default, as I’m on laptop this is ok for me), and after 80hex (I think around 7 minutes) the drive stops spinning. Way relaxed, before was after cca 15 seconds! So thanks WD for nothing. At least you should provide some information about this.

Hello,

Thanks for sharing the solution that you found.

Hope this help other users in the future.

Unfortunately, it’s only a fix, not a solution. CrystalDiskInfo has to be loaded with Windows every time to make this fix work. So it’s not a permanent solution. I’ve contacted WD. Here’s my mail:

Hi Carlos,

First I have to say that I use WD blue hard disk as my secondary disk, my primary/OS disk is a ssd. If you listen closely you can hear that after eight seconds of inactivity, hard disk parks it’s head, and after about 15 seconds of inactivity, the drive stops spinning. I admit I exaggerated a bit saying it happens after 5 seconds. After spending a day researching on internet I found this is a normal thing on this hard disk. However 15 seconds is still very short period. So in regular use my disk keeps spinning up and down therefore slowing down overall performance. Older WD hard disks continue spinning for cca 5minutes of inactivity, and I find that more pleasing for work. I wish that WD made clear that newer hard disks have such aggressive protection or energy management (whatever it is), because it doesn’t suit my need. Many people on the internet complain about this. There are many third-party utilities that allow to increase that period, however all these utilities have to be loaded every time OS starts. I would like that WD makes some small utility that would allow me to permanently increase the time after which hard disk stops spinning. I know that these hard disks are 2.5” and are used in laptops, which are then moved or ‘tossed’ around, and that this short time is a way of protecting the disk but still, performance and durability suffers if you have a disk that is constantly spinning up and down. I see WD (and it’s sister HGST) as a company that is no.1 in mechanical hard disks and I hope this issue will be resolved, and a solution will be offered. Again no problem with parking head after eight seconds, but a huge problem with spin down after 15 seconds.

Regards,
Danko

After some time spent researching I found a permanent solution. It’s a Linux utility called APMtimer. All my attempts to get help from WD Support were useless. They just don’t care, and it’s very sad. Also one more note, this may or may not void your warranty. Do it at your own risk.

Here’s the link
http://apmtimer.sourceforge.net/

The utility sets the spin down timer to your desired setting. The default timer setting is 20s, I set mine to 300s (5 minutes) and it works, the setting is kept after power cycle. The disk has also been to other laptops, but the setting is kept. I’m still testing it, but so far all 3 of my drives respond well. I will also post instructions. Now I must note that Linux is completely unknown to me, so all suggestions or further explanations to my ‘steps’ are more than welcome. I was basically relaying on trial and error method, but somehow I got it to work. I used Ubuntu, but Ubuntu didn’t well work on my newer laptop, it froze, so I started it on my older laptop and it worked like a charm. I must say it’s a delightful OS, and I will come back to it to poke around when I have more time.

Link to Ubuntu download:
http://www.ubuntu.com/download/desktop

Link to USB mounting application and instructions:

Steps

  1. instert drive into laptop (that supports Ubuntu)

  2. start Ubuntu from USB (allow storage space)

  3. unzip and copy apmtimer-1.0 files to Desktop using Ubuntu

  4. start terminal (upper left icon, type terminal)

  5. type cd Desktop (case sensitive)

  6. type make (this is not clear to me)

  7. type sudo ./apmtimer -g /dev/sda to get APM value

  8. type sudo ./apmtimer -s 300 /dev/sda to set APM to 5min (300sec)

  9. shut down and restart again in Ubuntu

  10. type sudo ./apmtimer -g /dev/sda to verify APM value

  11. finished

Until a better/offical soultion is given I will mark this as a ‘solves the problem’.