New Firmware required - WD Blue 1TB WD10JPVX

This drive WD Blue 1TB WD10JPVX with Firmware Revision: 01.01A01

required new firmware to fix hard disk drive spinup and spindown which addresses drive noise and intermittent freezing/stuttering.

Spinup and spindown like crazy every few seconds, and freeze all apps before spinup.

1 Like

“Spinup and spindown like crazy every few seconds, and freeze all apps before spinup.”

I have exactly tha same problem. I’m about to buy another hard disk (with another brand), because this one slows a lot my high performance notebook.

But if you fix it, it will be ok, of course.

Stefano

I just registered to this community for this specific problem. I have a WD10JPVX drive as a secondary drive on my laptop, and this problem is very annoying since it blocks my machine for a couple of seconds way toooo often. Gaming is impossible without disabling APM through third part softare. Please WD fix this!!!

Same problem here with WD10JPVX  notebook HDD, spin ups and downs causes 3 second lag in every program,  need an official patch for this. 

Great to see that others are annoyed too. Just bought a WD10JPVX to have as a secondary drive in my Intel NUC which I use for music production. I store all audio files i.e. recorded tracks on the the WD drive and the constant frenetic spin down/spin up is extremely annoying when I’m working. Waiting 3-4 seconds when pressing play every time the disk has spun down is ridiculous. And probably not healthy for the disk. I’ve tried wdidle3 and WdIdleDisable with the disk in an old empty WD MyBook case I had lying around. It makes no difference.

I wonder what the engingeers behind this fantastic mechanism was thinking the day they thought of the holy intellipark. It is one of the most [Deleted] tech implementations in history. The only reason I’ve kept buying WD disks was that you could use the WDidle tool. So the disappointment was enormous when it didn’t work. Please make a new firmware or this is my last WD drive.

So, I’m having exactly the same problem with this drive which is installed on my Mac mini.

WDC WD10JPVX-00JC3T0:

  Capacity: 1 TB (1,000,204,886,016 bytes)

  Model: WDC WD10JPVX-00JC3T0                    

  Revision: 01.01A01

It spins down every few seconds and then almost immediately as the computer requests it spins up again. Then it spins down and then it spins up again and then it spins down and then it spins up again. Several times a minute.

This is absolutely crazy.

Western Digital are you listening? Can you please supply a solution for this?

A software fix that I can use on my Macintosh please. I have no access to Windows.

This is surely bad for the drive as well as being extremely bad for working on the computer.

I’m having exactly the same problem. It’s hardly possible to work with such a harddisk, because EVERYTHING freezes for a few seconds and that happens maybe three times per minute. When I just scroll an internet page or an office document, the laptop suddenliy freezes for a few seconds and I have to wait until the HD spins up. That happens everywhere: Also In a painting program, when I type a text, just in every program. I called WD and they told me that they never heard about that before. I could send them the harddisk and get a refurbished harddisk as a replacement, if they found a problem. I could also use a software tool, but that would be my own risk.

Doing anything with a hard drive on my own risk doesn’t sound reasonable for me since I store the work of my own company on that HD.

It’s sad that WD doesn’t care about their customers. I already ordered another HD from a competitor.

I don’t see another way than taking the WD hard drive out of my computer, throw it away and never buy a WD device again.

Well, a few days ago I contacted WD after I discovered my hard drive was still under limited warranty. They have issued an RMA and are swapping my disk out for another one of the same type. I did point this thread out to them and I also sent an audio recording of my drive repeatedly spinning down and then almost immediately spinning up again (below).

They’re going to send me the same model (refurb). I have requested that they update the firmware on it first so that it doesn’t automatically spin down! My computer handles that function - I don’t need the disk to do it without any knowledge of what’s going on in the computer.

Here is a link to a 2½ minute section of audio when the computer was actually in the process of continuously recording a TV program to the hard disk/SSD Fusion drive, it starts at nine minutes into the image below.

image of audio recording

After discovering that my hard disk was still under warranty and having no success at navigating their website to send an email (which seems to go around in circles), I telephoned them and spoke to a very helpful advisor who opened a replacement RMA ticket. A week ago the drive arrived, I put it in an external hard disk box to see how it behaved. It ran and didn’t spin down every 22 seconds!

I tested it for quite a while - more than 24 hours, and I made an extended audio recording of it just to make sure. Nope. It stayed running, if I told it to spin down using the Keep Drive Spinning.app it spun down and stayed spun down. If I woke it up, it woke up and stayed woken up. So I made a full clone of my existing system, opened Terminal and unfused the fusion drive diskutil cs delete [Logical Volume Group], then erased it with the write zeros option and then replaced the drive with the new one from WD. After remaking the fusion drive and cloning everything back again the Mini is running like a dream now, perhaps even better than before now that I have more free space available. Problem solved.

When I spoke to WD before they were quite convinced that this particular model did not have the IntelliPower feature and didn’t spin down by itself, but here at the WD users forum there are several other people who have examples of that drive and say that theirs do. Perhaps there was a short period of time when they did actually let some out with that firmware, however this one doesn’t and so it’s all sorted now! :slight_smile:

The disk label shows the same disk model number, I assume the firmware must be different, even though it reports the same firmware version (Revision: 01.01A01).

Since the RMA was opened on 17 February, I found it quite surprising (and reassuring perhaps) that the date of the refurbished drive is only the day before! However something went wrong with the delivery, it took almost two weeks before it actually arrived though the documentation said it was shipped from Budapest on the 17th. I phoned them and told them it hadn’t arrived yet and then two days later it appeared in my postbox.

Hey Guys, have any of you found a way to fix this with some kind of firmware update?

I am having the exactly same problem. It takes around 20 seconds after every acess to stop spinning.

My HDD model:

WDC WD10JPVX-00JC3T0:                

  Revision: 01.01A01

I’m owning the same HDD and same firmware version and the problem has also plagued me a lot. Since there were no updates nor proposed workarounds, I’m reporting my discoveries and successful fix. With the tool CrystalDiskInfo, I observed that the default value for ATA APM (Advanced Power Management) for this WD10JPVX-22JC3T0 was 96 (60 hexadecimal), that should mean quite aggressive Power Management. Other older WD disks like WD10TMVW-11ZSMS5 and WD7500BPKT-00PK4T0WD, I observed a default of 128 (80 hexadecimal). Ubuntu Linux by default uses utilities to full disable APM with 254 (FE hexadecimal). Windows 8,1/10 seems to leave the found value and do not attempt any modification. So my suspicion is that this drive is shipped with an overly aggressive power management configuration that is unsuitable for configurations like dual SSD/HDD laptops, with the HDD not used as the system disk: this setup leads to frequent head parking events because of few writes. So eventually what I did is this:

  1. With CrystalDiskInfo[*], I set the ATA APM Control to the value of 128 (80 hexadecimal). The maximum is 254 (FE hexadecimal). 254 should mean APM disabled, but for me 128(80h) was enough;
  2. As I use HDD as a non system drive, I used the the old DOS util wdidle3.exe (version 1.05 has no more official download but can be found quite easily) to increase the timer for heads parking to the default of 8 seconds to the maximum of 300 (5 minutes). This setting alone was mitigating the problem but not fully fixing it. It could be done but I chose not to fully disable the timer.

Hopefully soon we won’t have HDD anymore in laptops so we won’t have to bother with this kind of problems in the future. Anyway I agree with other people that the HDD we are talking about deserved a firmware update providing a less aggressive default APM value. Still, more relevant technical information should have been provided sooner as “it doesn’t work, provide me an updated firmware” like reports are just gonna be ignored by WD.

[*] APM Controls is in “Function -> Advance Features -> AAM/APM Control”. As the set APM control setting is not persistent, check “Function -> Resident”, “Function -> Startup”, “Function -> Advance Features -> Auto AAM/APM Adaptation”.

1 Like

If you hear an autopark at 8 seconds, then you need wdidle3 or idle3-tools

If you hear an autopark other than 8 seconds, and APM is at 0x60, then APMtimer might help. A lot of models are 20 seconds, but some slim models is as low as 3-4 seconds.