WD Backup not installing!

I could not start WD Backup using WD Discovery. So I went to Support and downloaded WD Backup as a .zip file. Unzipped and opened. Offered to remove installed WD Backup. Skipped that, but then it quit. repeted and uninstalled WD Backup. Opened WD Discovery and requested WD Backup Install. Reported “Install failed.” Repeated with additional “Install failed”

Now no WD BAckup!


Hi Clifford_Cleary,

I would suggest to refer this KBA to uninstall WD Backup first,

Then reinstall updated version of WD Backup from WD Support.

I had already found that Install WD Discovery is supposed to include WD Backup, so I tried that, but it did not help. I just tried your suggestion, but it asks what program is not being installed and I answered WD Backup. First time I skipped tet on WD Backup and that failed. So I tried with WD BACKup and it ran for 5 minutes and I cancelled it.

This thing is very confusing because there is a program called WD Backup, but if I try to run that nothing happens, even before WD Discovery gave me trouble. The only way to do WD BAckup was through WD Discovery! Confusing!

I now have a Case into Support. See if that helps.

Ninguna de las soluciones que estáis dando resuelve el problema. ¡¡¡ RESULTA IMPOSIBLE INSTALAR WD BACKUP !!!