Very slow too add and for streaming

So, this week I decided to upgrade my entire media player setup. Replaced my PC with a Beelink Android box, and put my drives into an EX2 Ultra.

Took a while to get stuff sorted with the EX2, but while I was, I had the Beelink on Wifi about 18 inches away from the TPLink TL-WR1043ND 300Mbps Wireless N Gigabit Router and I was streaming from my shared folder on my desktop PC that’s plugged directly into the router. 0 issues, perfect playback.

Finally got the EX2 running JBOD and transferred over 3tb of movies to Disk1, Disk2 will be for TV Series whick I’ll transfer tonight.

On the Beelink which boots direct to CoreElec/Kodi, I tried adding Disk1 and then started the issues.

Like my PC’s share folder I manually added Disk1 with the IP address and username and password. Hung for about 90sec and added. Clicked Ok to finish, another 90sec. Went to the main screen to add the folder as an icon, another 90sec. Clicked to open, yup 90sec, finally opened and shows all files, and playback is slow, buffers constantly, total garbage.

So, back to the PC share folder for now while I research the issue, and now, what worked fine yesterday is playing like garbage.

Wiped the share out and rebooted and still garbage.

Seems that as soon as this EX2 was added, playback speed dropped. No files are downloading, no files transferring either.

Other issue was that my external 3tb plugged into the EX2 directly was transferring only at 28mbps max, so I plugged into the PC and transfered which brought it up to 38mbps. Weird but I guess normal from what I read.

Anyways… Bought too be used for media streaming only and although the Beelink will get Ethernet connected when done, the Wifi should be fast enough. It was yesterday before this was connected.

Any ideas?

Beelink specs are pretty high, router specs as well, and router less than 2 feet away, so full wifi signal…

You should try to troubleshoot with all the instructions in the below mentioned knowledge based article in order to resolve the issue. There can be the network configuration issue which is causing poor performance in terms of streaming content through My Cloud EX2 device.

I did… it wasn’t helpful.

I’m sure it’ll be fine when I switch to ethernet… replacing old cheap Cat5 with better Cat6… not so much for performance, just the ones I ran from one end of the house to the other were generic eBay brand, and just poorly constructed, sleeve is cracked and falling off, etc. Bought some heavier quality ones.

Still… be nice to sort out the WiFi issues because eventually I’ll be adding an extra box to the setup that will have to run off WiFi.

My WiFi now is a cascading network… I have the 100mb up/down fibre optic modem/router combo at the front of the house, and the ethernet cable running to the back (where I am) with a TPLink gigabit router. The android box (Beelink GT1 Ultimate TV Box Android 7.1 DDR4 3GB ROM 32GB Amlogic S912 Octa Core Support 4K H.265 Output 1000Mpbs/LAN Dual WiFi Media Player) is maybe 5’ away from the TPLink.

I have tried switching between connections (regular and 5G) and no change. Signal strength 100%. Ookla speed test shows between 75-78mbps for both up and download connection speed.

WD EX2 is connected to the TPLink router with the provided ethernet cable, which is the router next to the Android box. The box itself I have dual booted, and boots direct into CoreElec running Kodi.

Connecting to the WD EX2 is also very delayed.

When in Kodi, I add the network drive as a source and takes well over a minute to confirm the address. Then I click add and it hangs for over a minute again. When I click to open the directory, yup, hangs again. Not sure if a connection speed issue? or just really slow at authenticating credentials?

Yeah, sounds like a network problem to me. I assume you did the obvious and rebooted everything?

Is the Beelink basically a media streaming device? Or is it meant to be a media server in it’s own right? It sounds like the Beelink is acting as a server, reading media files from the EX2.

Communication is generally dictated by weakest link. In my house, it is the WiFi in the router. You mentioned a 300mps wifi? That sounds a bit low end by today’s standards; and might be a first place to look. What happens if you put an ethernet cable between the Beelink and the router? You mentioned 75mbps up/down connection speed. That’s speed between what and what? The beelink to the ookla server? That ought to be enough.

It sounds like you definitely have a connection problem to the EX2? Is it just with the Kodi software, or does other media software have the same problem? Can you run VLC on the Beelink?

To confirm that the EX2 is a problem; why don’t you try to use the PC as the file server for the Beelink? If that works better, then you know it is the EX2. I would go into the router settings and see if there is something hinky in the DHCP settings. I tend to use static IP addresses to help avoid conflicts.

My home setup is a NAS wired to a gigabit router, then wifi to a roku stick plugged into a hometheater system. The roku is basically a receiver, with the NAS performing both file server and media player funcitons. I never see difference in performance between the 2G and 5G bands on the router. Both Plex and Twonky media players (with the NAS as the server) work fine. I also stream from the NAS to VLC on an android tablet and on a PC. That works fine as well. (in those cases the NAS is simply a file storage device)

I disagree with the router being the issue or slow/low-end… The router is a TP-Link TL-WR1043N 450Mbps Wireless N Gigabit Router, and was bought 2yrs ago, which is when the WD EX2 was released, so, the NAS shoulda been tested with routers available at that time and the speeds that they ran at. You can’t market the NAS as being great for basic home use and expect people to have $400 routers that they replace on a yearly basis with an updated model. Plus, switching to 5G connects me to the fibre optic modem/router itself which is only a few months old. Most people don’t have a cascading network at home, so I’d assume most people would have whatever their ISP provided to them and nothing more. So… one of the routers should be stutter free.

Plus… I’m not talking about 4K video files with H265, 15000kbps bitrates and 20GB etc… I’m talking about 600mb H264 MP4 files with a bitrate around 2000kbps.

According to most sites, you should have at least 3-5Mbps for streaming HD content from sites like Netflix. Ookla is an internet speed test, which again shows my WiFi speed on the android box to be >75Mbps. 15x the recommended speed for streaming. That’s connecting to internet, connecting to the router should be better because no lag or speed issues connecting to some web server in another country, busy times, etc… communication between the android box and the router should be uninterrupted and steady.

Everything has been rebooted, static IP, and even did a full reset of the NAS and set it back up again.

This weekend I’ll finish replacing the old Ethernet with new Cat6e higher quality cables. Won’t affect my setup it’s for the other systems in the house, but will free up a port that I’ll use to connect my android box directly to. However, we’re adding a TV in the house that the box will only have WiFi access to so, still need to sort out what’s happening.

When the 2 drives were in the old QuadCore HTPC that I had running as a media server. 0 lag ever on any device in the house even watching 1080p H265 video at 5000kbps.

Understood - - - -> Yes, if you are getting a great speed test from the Android Box to the internet, then the router/android box wifi link isn’t the problem. Not clear that upgrading to a Cat6 wired connection will help.

If we are ruling out hardware connection speed… . .that brings us back to the network software setup.

No… it won’t… not for the wireless. Like I said “Won’t affect my setup it’s for the other systems in the house, but will free up a port that I’ll use to connect my android box directly to.”

Originally, the modem was at the rear of the house, it plugged into the router and I had 75’ of Cat5e running to a router at the front of the house for the cascading network, and another 75’ Cat5e to another computer at the front of the house.

It was cheap cable, the blue sleeve was cracking and falling off the day I got it, the ends were poorly connected as well.

We switched from DSL to Fibre Optic a few months back, and when we did they installed a modem/router combo at the front of the house. So I removed the small router I had and used the one at the back of the house for the cascading network using the 75’ cable already there. But the PC at the front of the house is still using the other 75’ cable.

I bought higher quality Cat6e cable, I’ll replace the 75’ between the modem and my router for the cascading network, and I’ll replace the other 75’ cable with a 25’ Cat6e and plug the one PC directly into the new modem. That will free up a port on my router for the android box to use.

So, the router I use will have the incoming connection from the router/modem on the new Cat6e. The other 3 ports will be my PC, the NAS and the Android Box.

How did you make out on this topic?

Honestly… no idea. :slight_smile:

So… had the one 3TB drive that was giving an error, found a good sale on WD Blue drives, and decided to upgrade to 4TB sooner than expected.

Installed 2 new 4TB drives, set to JBOD, and did not touch any other settings at all on the NAS, router or Android Box…seems to be working fine now. So, ya… not sure if fixed itself, drive issue caused slowness, temp/intermittent and will return again… ?

For now, I’m streaming with WiFi and seems fine. Nothing changed except the two drives.

That said, anything like 4K 10bit H265 video tends to stutter/buffer, but on WiFi that’s what I expected to happen. Should probably be fine when on ethernet, but honestly, just had a few files to test with when I get a new TV next month. Likely though, won’t see 4K too often due to file size. Most files I have at most are 1080p H265 8000kbps.

That may change when I go from a 10yr old Sony 40" LCD to a 55" 4K LED… but right now, my 1080p files look just fine.

Hopefully it just keeps working the way it has been the past 3 days.


But at least it is now working.

At some point. . .I will want to understand your HD upgrade path. . .is it pretty much plug-and-play when you are set to JBOD?

I suppose my path will be more complicated, as I will want to maintain Raid 1 in my EX2. I am half thinking to be lazy and just buy a new box for the drives. (probably a PR2100 --> Silly me will want the chip).

Well, original setup was 2 drives in my old pc, one drive just movies, one drive tv series. I also had 2 external drives, 1 for each as a mirror backup.

So, when I setup the NAS, it made sense to keep the setup the same.

I didn’t want a RAID setup because would make backups harder than need be, plus I don’t trust it… So many threads about one drive dying and can’t access files on the other or rebuild not working etc…

1 drive movies, 1 external drive for mirror backup.
1 drive tv series, 1 external drive for mirror backup.

JBOD was easy to do… Just put the drives in, click switch to JBOD and done. On my Win10 PC I mapped each drive as well as on the Android box.

Access wise, I have 2 accounts setup, admin and family. Admin has read/write access which is my account, all the other devices in the house use family with read-only access to prevent them from deleting stuff. Sometimes they just start clicking and not reading popups or warnings so, read-only access for them. :slight_smile:

Figured this was the easiest safest setup, and backups are on a shelf safe from viruses or power surges. A drive goes down, I can replace it and just copy over from backup.