NAS - various reliability issues and some nitpicks


Hopefully someone can help me trying to get my WDMyCloud EX4100 to be more reliable in terms of speed (as in, playing back full-size blu-ray rips over wifi without stuttering) and not disconnecting.

Basically, I made a post at the HomeServer reddit that explains it all.

Is there a difference between clicking on the WDMYCLOUD network icon vs the generic icon? lead to different directories. Also, what’s the DLNA server that runs in the WDMyCloud? Is it Twonky, or something else? I ask because that might be how to not have to go so far into directories to get to my “Share” folder I’d rather just get to right off the bat. I have to navigate to /Videos/By Folder/Movies-from-NAS everytime instead of going straight to Movies-from-NAS.

Thanks in advance!:blush:


Update: I got a TP-Link Powerline Network Adapter for the downstairs so I can wire up the Oppo player to ethernet…the video still stutters.

Can anyone at least comment on the folder structure problem? Surely that’s related to the WD device?

…ok - thanks for replying, at least. Yes, I really did want an answer, so I’m not sure where the “You want an answer…you won’t like it” buildup came from, or why you felt that was warranted, but at least I got something now. I wasn’t really asking for subtlety or anything, I’m honestly just trying to figure this out. Glad I could be the one you could take out whatever mood you’re in to contrast whatever mood you weren’t in the mood to be in.

Can you please elaborate when you say the EX4100 can’t handle streaming very well? It was the device the IT guy picked out when I told him exactly what I was wanting to do, and it seems to handle streaming full HD Blu ray rips just fine in the upstairs room wired directly to the router. Is it the EX4100 device itself, or is it the server software that is uses when streaming media content?

I certainly don’t think it’s the wifi, it’s pretty fast and can certainly handle streaming over wifi in the other room upstairs, even full Blu ray rips, or even full wav files streaming music downstairs.

I think you are mixing up terms here. Streaming and transcoding. I have the EX4 which is even older than the 4100. It streams perfectly fine. It is actually overpowered just for streaming. I can stream 50 GB rips of Lord Of the Rings without one stutter. I am using ethernet not wifi so that could factor in. I have two Kodi boxes on two separate televisions both wired directly to my router and have never seen one stutter when watching a movie off the EX4 NAS. Now if you are using Plex or something like that and trying to watch a movie on an iOS device which it would have to transcode first then it would not work as it is not nearly powerful enough. It takes very little hardware power to stream a file on the NAS to your local network, provided you have enough bandwidth on your network and it is wired properly. I have had my EX4 for about 4 years now. Never had a hard drive failure, never had a drop out. Nothing. It is worked extremely well for what I use it for. If you are just trying to stream a movie to one of your televisions and are having stutters; I would look at your network and then whatever software you are using to watch the movies on your television. The 4100 will have absolutely no problems whatsoever streaming a movie to your television if everything is set up properly and your network is up to the task.

Yes forgot to mention that. Turn off Twonky and any media server and you will have no performance issues. When I had Twonky on, the CPU on the NAS would always be maxed out. It’s useless. Use Kodi or something similar to stream the movies on your local network and it will be more than enough for your needs. But if you want transcoding or anything more than just local network streaming, the 4100 will not work. You would need a much more powerful NAS such as some of the ones geared towards media transcoding from Synology with much faster CPUs and upgradeable RAM.

I’m not using Plex, just using whatever software my Panasonic and Oppo players use simply for streaming a movie on the network.

In the past 10 minutes, I took the Panasonic player that was upstairs directly wired to the router and put it downstairs, and hooked it up “wired” from the TP-link powerline adapter and tried playing back the same file. Same stuttering issues. So maybe it’s a combination of WD’s Twonky server software it uses to serve as a media server, and my network strength downstairs? Is there a device I can connect between the TP-Link and my player that has a digital readout that shows the actual speed I’m getting?

If you have Twonky on, that is most definitely causing your stuttering issues as it utilizes all available CPU cycles. That’s why you need something like Kodi to take the overhead off the NAS and only use it for streaming.

Here’s a screenshot of my settings using the browser interface for the 4100.

I don’t see anything specifically that says Twonky, but I’m assuming that’s what it is when I turn on Media Serving?

Thanks for your time then guys. I’ll try that, and possibly might hire another IT guy to get another perspective. I’m still curious what the actual network speed I’m getting at endpoints as opposed to what the devices are theoretically capable of doing. This whole thing is maddening…I’m not even considering Plex or anything at this point, just trying to stream a file across a network without stuttering.

Go to the media section in the settings and turn off all media streaming.

Easiest and cheapest solution is to get a Raspberry Pi 3 for around $30 and install LibreElec (Kodi) on it and you can easily stream any movie to your television stutter free.

Ok, I did that just now, the upstairs player doesn’t see anything, but the downstairs player still sees the wdmycloud as a networked drive, so I tried playing back a blu-ray rip with Twonky disabled. still the same stuttering issues. I checked the CPU usage of the 4100 and it’s pretty low with the Media server disabled. I’m thinking it’s just a connection bottleneck issue - I might just have to get a (different) technician in my house and get a second opinion.

i know this is old, but truly doubt you can stream any HD over wifi with this device

it’s just TOO ■■■■ slow

GB is fine though even with UHD

Nah man, I welcome any new input on this - this problem’s still unresolved. I ended up resorting to getting another drive and plugging it locally into the usb port of the blu-ray player itself. I could never get blu-ray rips to play back stutter-free over the network.

So you’re saying it’s the WD device itself that’s too slow, and not my network?

What do you mean “GB” is fine though… is GB another WD NAS model?

GB=gigabit and yes…copying to the drive lucky to get 30 or mb/s, that’s pretty slow

I use an egreat a5 media player

Last night watched a uhd remux stutter free