WD My Cloud 3TB + RasPi2 + Kodi = unendlich langsam

Hallo zusammen,

ich habe ein Problem mit meiner brandneuen WD My Cloud 3TB im Zusammenspiel mit meinem Raspi2 auf dem Kodi 14.2 läuft. Ich kann keinen Film richtig schauen, ohne dass alle 10 sec gepuffert werden muss! Unter Kodi habe ich die Freigaben als SMB eingebunden. Nach einem Tipp aus der Community habe ich es einmal per NFS versucht, aber er puffert trotzdem alle paar Augenblicke.

Ich habe noch ein uraltes NAS-System (D-Link DNS-323 aus 2008) im Betrieb. Mit diesem steinalten Teil funktioniert alles ohne jedes Puffern. NAS und WD My Cloud hängen übrigens am selben Gigabit-Switch. Durchtauschen von Kabeln und Ports am Switch brachte keine Änderung. Vom NAS läuft’s perfekt und bei der WD muss ständig gepuffert werden.

Das lässt ja nur den Schluss zu, dass irgendetwas mit meiner WD My Cloud nicht stimmt.

DLNA-Medienserver und iTunes-Server habe ich abgeschaltet, weil ich sie nicht brauche und auch im Verdacht hatte, dass sie meine Cloud ausbremsen. Hat aber auch nichts gebracht. Ich vermute aber trotzdem, dass da irgendwelche Dienste (Indizierung?!) laufen, die die Cloud ständig beschäftigen.

Kann mir jemand helfen? ich werde noch wahnsinnig. :frowning:

Vielen Dank schon einmal.

Deezle

Hi,

ich habe eben mal versucht ein Video über VLC direkt, also ohne DLNA, auf meinem PC zu schauen. Und was soll ich sagen … tatsächlich auch bei mir wird 2 x gepuffert. Nicht unbedingt alle 10 sec. … aber dennoch kenne ich diese Phaenomen bei der DLNA übertragung nicht. Vielleicht hängt das auch mit der Dateigröße zusammen und der MediaArt (avi. mp4 etc).

Ich schätze mal das die Hardware der MyCloud, bis auf die HDD, darauf nicht ausgelegt ist. Der Prozessor ist nicht der schnellste und der RAM Speicher ist auch nicht der Größte. Dafür hat sie andere Qualitäten.

Mein altes NAS von 2008 hat garantiert den langsameren Prozessor und weniger RAM, aber funktioniert noch bestens. Und das mit denselben Dateien.

Die Dinger haben nicht nur wenig Speicher und eine schwache CPU, die sind auch ansonsten eher schwach. Mir erschließen sich bis jetzt keine besonderen Vorteile gegenüber anderen Systemen …

anyway, vielleicht ist dir noch nicht aufgefallen, dass die Kiste in allen möglichen Verzeichnissen, versteckte Verzeichnisse .wdmc anlegt. Hier werden ungefragt thumbnails von vorhandenen Bildern erstellt, für eine MobilApp, die du möglicher Weise gar nicht nutzt. Selbst wenn gar keine Bilder auf der Platte sind, wird andauernd gescannt ob du nicht doch zwischenzeitlich eins gespeichert hast . Als  Weiteres läuft im Hintergrund ein recht kräftiger Task, falls du mal über USB eine Kamera anschließen solltest und die Bilder direkt übertragen willst. Sinniger Weise lassen sich diese Ressourcenfresser im Cockpit NICHT abschalten.

Da du den Raspberry hast, kennst du dich mit der Shell aus

/etc/init.d/wdmcserverd stop

/etc/init.d/wdphotodbmergerd stop

wären die beiden Jobs die du stoppen solltest, dann dürfte das funktionieren. Bei mir kann ich problemlos per VLC Filme schauen …

1 Like

Hallo 3Dscrewer,

diese beiden Prozesse hatte ich bereits ausgeschaltet. Das hat aber keine Abhilfe gebracht. Da ist offensichtlich noch jede Menge anderes Zeugs, was die Cloud ausbremst. Ein User aus dem englischsprachigen Forum hat mir geraten folgende Prozesse zu killen:

/etc/rc2.d/S85wdmcserverd stop
/etc/rc2.d/S86wdphotodbmergerd stop
/etc/rc2.d/S92wdnotifierd stop
/etc/rc2.d/S20winbind stop
/etc/rc2.d/S85twonky stop
/etc/rc2.d/S50netatalk stop
/etc/rc2.d/S60mDNSResponder stop
/etc/rc2.d/S95wdAutoMount stop
/etc/rc2.d/S20nfs-common stop
/etc/rc2.d/S20nfs-kernel-server stop
/etc/rc2.d/S61upnp_nas stop

Das hat schon ziemlich viel gebracht, aber es ist immer noch nicht ok.

  • SD-Filme: Es jetzt vielleicht alle 5 min gepuffert. Besser als alle 10 Sekunden. :slight_smile:
  • HD-Filme: alle 20 oder 30 sec hängt der Film ein paar Sekunden. Es erscheint aber keine Puffermeldung.

Irgendetwas bremst da immer noch. Am Liebsten würde ich alles ausschalten, was die Kiste nicht unbedingt benötigt. Da meine Linux-Kenntnisse aber mehr als bescheiden sind, weiß ich nicht, was ich alles ungestraft abschalten darf.

Deezle

Hi,

was ich noch nicht ganz verstanden habe…

Warum spielst Du deine Filme nicht einfach mit einem DLNA-fähigen Bildschirm/TV ab? In der heutigen Zeit kann das doch praktisch jeder TV (jeder der Netzwerkfähig ist, was die meisten ja mitllerweile sind).

Stattdessen lenkst Du einen Datenstrom auf einen MiniRechner und schließt den … (wo an?)

Oder willst Du basteln?

Ich denke einfach das DLNA Protokoll ist etwas anders gestrickt. Und so kann WD zwar einen MediaServer anbieten, der jedoch als FileServer (Datenbankserver) kläglich versagen würde.

Der DLNA Server (ich kann mich hier nur auf die EX4 beziehen) ist ja auch nur halber kram. Ich habe einen UE55H6470 der kann sogar 5G WLAN und hat direkte Sicht auf den Router. Sobald ich via DLNA nur 320K Audio Material höre (via Toslink auf Receiver) und jemand eine  Datei sucht und/oder jemand die Jobdateien für CNC rüberkopiert, kriege ich die Meldung Server nicht gefunden.

Kodi ist ähnlich wie Plex aufgebaut, hat ne tolle Oberfläche, Plex überfordert das CPUchen aber auch völlig, selbst mt den abgeschalteten Tasks. Plex läuft bei mir jetzt sage und schreibe 7x24Std und ist mit den 120.000  MP3 immer noch nicht fertig. Ich habe mittlerweile meinen alten W2K3 Server wieder dazwischen gehängt.

Jetzt wo es warm ist, stinkt es bei mir im Büro nach verbrannter Platine, mal gucken was passiert.

Nebenbei mein TV hat eine Plex App, sieht ganz witzig aus und die App für iOS kostet 5 Euronen, Android kostenfrei… :confounded:

Wie ist der Raspberry eigentlich angeschlossen?  Per WLAN 54MBit, oder 100Mbit Kabel? Vielleicht hat der Switch ein Problem, bzw hast du überhaupt nen Switch dazwischen? Die Home Router die ich so kenne Switchen z.B. gar nicht.

Ansonsten vermute mal der Raspberry ist schneller und besser als die WD Geschichte, ich hatte mal ein ähnliches Teil.

Hast du die anderen Tasks überhaupt abschalten können? Bei meiner EX4 gibt es kein \etc\rc2.d\ soweit ich das bis jetzt gehört habe, ist die Verzeichnisstruktur gleich (aber ich habe nen Tinnitus) :smileyvery-happy:

1 Like

Hi Lucky,

wenn Du auch nur einmal ein gut laufendes System mit XBMC oder Kodi gesehen hättest, würdest Du Dich angewidert von jeder Abspieloption auf einem TV abwenden. 

Und der Raspi2 funktioniert fantastisch mit meinem Uralt-NAS. Er spielt alles(!), was ich ihm vom NAS vorgeworfen habe, klaglos und ruckelfrei ab. Egal ob SD oder HD. Und die Hardware im Raspi2 ist höchstwahrscheinlich 99% wenn nicht sogar 100% der Hardware in jedem beliebigen Consumer-TV weit überlegen. Was glaubst Du denn, was die Hersteller dort verbauen? Auf keinen Fall Hochleistungshardware. :wink:

Deezle

Hi 3Dscrewer,

der Raspi2 ist per 100MBit LAN angeschlossen. Nix WLAN. Der Raspi2 bezieht einerseits Daten von meinem Uralt-NAS DNS-323 von 2008. Das funktioniert in jeder Hinsicht fantastisch. Die Performance ist perfekt. Andererseits bezieht der Raspi2 auch Daten von der WD My Cloud 3 TB, die ich gekauft habe, weil es auf meinem NAS ein wenig eng wurde. NAS und My Cloud hängen am selben Switch. Kabel und Ports habe ich schon zur Genüge durchgetauscht. Ein Netzwerkproblem auf dieser Seite erscheint mir so unwahrscheinlich wie ein Sechser mit passender Zusatzzahl im Lotto.

Doch, doch, das Verzeichnis /etc/rc2.d existiert tatsächlich. Ich habe zwar nicht jeden Prozess stoppen können, aber dies lag nur daran, dass ich über die Weboberfläche bereits DLNA und iTunes abgeschaltet hatte.

Hast du nen HUB oder nen Switch?
Ich würde die Cloud mal testweise auf 100M festnageln. Hast du was von AVM dazwischen? Die können z.b keine Jumbo Frames.
Hast du mal deine alte NAS und die Cloud angepingt und die Latenz überprüft? Hast du die Cloudsoftware mit Backup auf dem PC installiert und der PC ist gleichzeitig an? Die WD-Programme machen lustig Traffic im Netz :wink:

Hab das gerade erst gerafft, Raspy 2 !!! Der ist der Cloud ja haushoch überlegen… nur schade die 100M

1 Like

Ich habe einen Gigabit-Switch. Kein AVM dazwischen. Am Switch kann ich nicht einstellen, ob ein Port mit 100 oder 1000 MBit betrieben wird. Kann ich das an der Cloud einstellen? Wenn ja wie?

Keine Cloud-Software auf dem PC. Brauche ich nicht.

Die 100 MBit vom Raspi2 stören nicht wirklich. Ist ja immer noch schnell genug für HD.

Im Cockpit ganz rechts unter Netzwerk und dann auch gleich den DHCP ausmachen und feste IP eintragen. Das liest man auch immer wieder …

1 Like

3Dscrewer wrote:
Im Cockpit ganz rechts unter Netzwerk und dann auch gleich den DHCP ausmachen und feste IP eintragen. Das liest man auch immer wieder …

Feste IP habe ich sowieso vergeben. 100 MBit lässt sich nirgendwo einstellen.

So sieht das bei der EX4 aus …

Da deine Kiste ja auch 1000/100 kann, sollte das auch ein Menue dazu geben :wink:

Wenn du Dateien kopierst, wie flott oder lahm bist du denn dann. Ich komme als einzelner Nutzer fast immer an 10MB/sek, was ja auch reicht … aber auch fast 100Mbit sind.

Hi,

@Deezle

“…wenn Du auch nur einmal ein gut laufendes System mit XBMC oder Kodi gesehen hättest, würdest Du Dich angewidert von jeder Abspieloption auf einem TV abwenden…”

Na ja, jeder eben so wie er mag. Ich gehöre noch zu der Kategorie die im DLNA Menu des TV’s einen Film auswählt und Diesen dann per Knopfdruck (in der Tat, so fortschrittlich ist es denn doch schon) startet. 

Gibt’s da noch mehr was ich machen w(s)ollte um einen Film zu gucken? Oder verpass ich was, wenn ich mehr machen müßte um einen Film zu gucken?

Edit 1: Nachtrag… ich würde übrigens tunlichst darauf verzichten den DCHP auszuschalten. Gibt nur Ärger…wie man so ließt…

Du bist schon krass drauf, oder (liegt das nur am Wetter)? Es gibt eine gut funktionierende Branche die primär Smart Funktionen in HDMI-Stick Version nachrüsten, weil halt nicht jeder einen neuen TV kauft um solche Funktionen haben zu wollen. 

Du wirst lachen, Kodi läßt sich mit der Fernbedienung bedienen, so komfortabel ist das nun auch schon.

Und so ein Verzeichnis bringt jeden DLNA Player weit ÜBER seine Grenzen, denn das läßt sich schlicht und ergreifend nicht mehr bedienen. Wenn noch die Musikclips, diverse Fotos und übliche Videodateien dzukommen, geht gar nichts mehr …

In dem  Verzeichnis befinden sich schon 780 Interpreten = Verzeichnisse, da hat man per DLNA schon zu tun um nach M zu kommen und die eingeschränkte Anzahl der abbildbaren Zeichen ist auch nicht der Knaller.

musik.png

Bezüglich DLNA, entweder gibt es unterschiedliche Aussagen bei unterschiedlichen Geräten, oder unterschiedlichen Firmwareversionen. Ich lese immer wieder -ABSCHALTEN- aber generell sage ich immer, Versuch macht klug (zumindest bei den Meisten)

Wollte ich die ganze Zeit schon immer tippern …

ssh -> top eintippern und du siehst wer die ganzen ressourcen braucht… es muss ja nicht zwingend an der Box liegen

1 Like

Hi,

@3Dscrewer

“… In dem  Verzeichnis befinden sich schon 780 Interpreten = Verzeichnisse, da hat man per DLNA schon zu tun um nach M zu kommen …”

Da gebe ich Dir recht. Nur das hier Raspi&Co an einen TV angeschlossen sind. Und mit dem sieht man funktionsbedingt eigentlich eher Fern… als sich dem ausschließlichen Musikgenuß hinzugeben.

@3Dscrewer

“… und die eingeschränkte Anzahl der abbildbaren Zeichen ist auch nicht der Knaller…”

Also das wundert mich jetzt doch etwas. Textbasierende Darstellungssysteme sind eigentlich seit Ende der 80’er nicht mehr so im Trend. Ich operiere dann doch lieben mit kleinen Bildern (Icon nennt man sowas). Da kann ich bei DLNA sofort erkennen um was es sich handelt.

Und die Auswahlmenüs meiner ~600 Alben, die auf meiner MyCloud liegen, werden von Apps aufbereitet und können dann direkt, per Tablet an die Musikanlage gehen.

Aber wie gesagt, jeder wie er mag. Ich sehe eben z.Zt. noch keine Vorteil darin  Raspi&Co, als Zuspieler aber auch zusätzliche Fehlerquelle der Übertragung, dazwischen zu schalten

Mir ist das schon klar, dass ausschließlich das zählt was dir gefällt.

Gestern war es noch die Fernbedienung, heute ist es das Tablett. Ich will mir kein Tablett kaufen, damit ich Musik hören kann, dann kann ich auch direkt von iTunes Match per Airstream an die Anlage. Nicht jeder muss unbedingt die neuesten Gadgets haben, aber das hatten wir schon.

Ich beschäftige mich seit Anfang der 80er mit verschiedensten IT-Bereichen, ich weiß was Icons sind und du erklärst mir bitte wie man aus der handvoll Farben die Inhalte ableitet  :wink:

Über Alben oder Interpreten (8165 wg. Sampler, 7291 Alben) ist der Weg noch langwieriger.

Da ist der Weg via RASPI und USB2TosLink immer noch der bessere Weg, den ich aus dem Freundeskreis hinreichend kenne, nur sind es da der Odroid XU3 mit Octacore Exynos.

Nebenbei, ich habe auch einige Tausend Musikclips und normale Videos, die ich der WD Geschichte schon gar nicht zumute.

Naja, aber das hat mit der ursprünglichen Sache nichts mehr zu tun … und es zählt ohnehin nur deine Meinung, also du hast vollkommen Recht …   :smiley: :smileyvery-happy: :wink:

Top in SSH habe ich gemacht, aber da war kein einziger Prozess auffällig. Ich habe aber einen Tipp aus dem englischsprachigen Forum bekommen, dafür zu sorgen, dass die My Cloud sich nur über 100 MBit verbindet. Und siehe da, die Probleme sind wie weggeblasen. Die Erklärung dafür soll sein, dass die My Cloud sehr große SMB Segmentgrößen verwendet. Über 1000 MBit kann das Netzwerk oder der Raspi2 überlastet werden. Bei 100 MBit eben nicht. Jetzt muss ich nur noch herausfinden, wie ich die Segmentgrößen auf der My Cloud korrekt einstelle und ich die My Cloud wieder bei 1000 MBit betreiben kann.