Verizon & WD My Cloud

Is anyone having issues with accessing their My Cloud through Verizon’s Cell network? We use it for work purposes and our IT company we do most stuff through has been to access it on everything else besides Verizon’s network. They have tried Sprint, US Cellular, T Mobile, our Wireless and theirs. Since this is out of their support area they are having us contact Verizon but I figured I’d check to see if anyone else has this issue and if they have found a work around.

What issue are you having? With what app? On what phone OS? Over which cellular (3x, LTE, etc.) Verizon network?

I have NO problems using the WD My Cloud app on my Verizon Wireless Android phone to access two different My Clouds (each in a different state).

I am having issues with WD My Cloud with both Android & iOS over LTE. I get Network Connection Error 905

Do you have the same problem if you connect the mobile device to the same local network as the My Cloud and access the My Cloud using the WD app? Have you tried removing/uninstalling the app and reinstalling it and reconnecting to the My Cloud using your web portal account?

Just tested my Android device again and no problems accessing a My Cloud remotely using VZW’s 4G LTE data service.

Yep, I have tried uninstalling reinstalling, I have no problems on WiFi and local network just Verizon. I saw a thread with someone with the same issues but there wasn’t any solution listed.

One suggestion is to change the remote access configuration on the My Cloud to use manual ports, then change the port numbers to something like 8080 and 4443. You will also have to configure port forwarding on the router the My Cloud is behind (connected too) as well. Maybe VZW in your area has trouble or is somehow blocking access to the default ports used by the My Cloud remote service.

All those settings are in place. I will see if Verizon is able to answer anything.

After looking at the previous thread it does look like it is on WD end. Guess I will try my luck with their support…

When I have seen error 905/906, it’s because my router has had its IP address changed due to rebooting, and had broken the connection with the WD servers. Toggling the Cloud Access setting re-establishes the connection.

I am still getting issues after trying that. Even tried rebooting after.

What does the Dashboard report for Cloud Access status?

One other thing to try is in the app, ‘forget’ the device (Menu/Manage devices/ hit ‘-’), and then re-connect. Do this locally. It may re-establish the connection.

I’ve tried that and Cloud Access is connected. I have also tried removing and reconnecting multiple times.


I have V LTE and there is no issue,but i’m in San Diego.

Step #1 Use a computer connected to the same router as your My Cloud and go to and get the external IP of your network,

Step #2 Used your iOS of Android device and download a networking app. I like iNet Tools on iOS

Step #3 Use the tool to

  • check to see if port 443 is open on your networks external IP
  • DNS lookup of and

One of the two should tell you something.

I have had our IT Department look into it and they said everything seems to be good.

It looks like both ports have the status “failed” is this something that WD can correct or is it something the IT Dept needs to address.

Here is a suggestion as a troubleshooting step. Take the My Cloud and set it up at home or some other location outside of your work network and see if it continues to have the issue with Verizon. At the very least that will potentially eliminate your work network as a potential cause.