Invalid Request 404 on Android, can't access the My Cloud away from the home, fed up now!

Hi all

Since purchasing a 3TB WD My cloud at the beginning of December im still yet to have the system working as its ‘supposed’ to.

At home via my own wifi connection I can connect to the drive using both my Windows and MAC laptop with no problems.

On my LG G3 Android Smartphone I can also connect to the drive at home via wifi but I am unable to connect via 3G / 4G. When I attempt to connect via 3G/4G the app hangs (circle timer) for ages and then I get a ‘network connection error 905’

I puchased a Lenovo tablet running Android 4.4.2 for the other half and today I installed the WD My Cloud App to that and activated it by getting the activation code from the WD Dashboard.  The tablet will not connect to the drive via the app at all, even though its connected to my home Wifi.  On the tablet I get the error messsage ‘Invalid Request 404’

Ive tried re-installing the app on bothe devices but I get the same problems every time.  The status for each device in my dashboard is exactly the same but one will connect via my home wifi and one will not.

Ive contacted Tecnical Support via email and have a very long string of emails suggesting settings checks, firmware updates etc, all which Ive completed but still I am unable to obtain any remote access despite the settings on the dashboard supposedly being correct. Before Christmas I requested that my issues be escalated to the next level and was told this would be done but since then Im yet to receive a reply from WD.

Ive read about possible router port issues that my be causing the remote access problems but WD Tech Support haven’t mentioned this in any of their recommended checks so far by email so I wouldn’t really know where to start with that.

I purchased this hardware specifically to access my drive away from home as I travel a lot through business but so far all Ive got is a NAS drive that can only be accessed at home. And an expensive one at that.

Ive read through the reviews of the WD My Cloud App on the Android App store and it seems that many many people are experiencing the same or similar problems so this must be something that WD are aware of.

I would be interested to know if anyone actually has a completely trouble free set up where they can access the drive at home via wifi, away from home via another wifi source, and also via 3G/4G on an android device.

I am becomming increasingly frustrated as a result of my experience so far with this product.

Has anybody has similar problems that have been rectified and if so, please can you share any solution ideas ?

Regards,

Hello there,

What you can try to do is getting a earlier version of his application, you can try and google it to see if you are able to get it and see if it makes a different on your phone.

I’ve tried that already with no success.
Thank you for the suggestion though.
Still no further reply from WD since being told my problem has been escalated, despite sending them another email chasing it up.

It could be ISP/mobile network who is filtering all these remote connections via their proxy, even those transparent ones. For this, you could manually map the ports to standard ones http/s 80/443 instead of those automatically mapped by upnp. It could be something else too.

If you still have the patience, let’s start from the beginning as I’ve no idea what you’ve shared with WD Support, am just a regular user here with no remote access issues.

  1. Post a screenshot of your WD Dashboard Settings -> General -> Cloud Access. Then click on the small configure, then manual. Take a screenshot or let us know the http/s values. If possible upload it elsewhere as it needs mods approval before we could see those uploaded here.

  2. Let us know your router brand/model. Post the screenshot of its:

    a: UPNP settings, if any.

    b: Port forwarding settings.

  1. From your mobile network, open the browser app, go back to this post and click on this link  http://nazar.bagus.org:8245/installer.fcgi?count=all and you should see a blinking image served from my wdmycloud.

Hi Nazar78

When i get home from this eve (uk time) I will update you with the information you requested thanks.

I am reading this post via my smartphone, so have clicked on your link and yes i can see the flashing text.

Regards,