UTF-8 Support over FTP

Hi,

I have the My Cloud Mirror Gen1. I’ve successfully set up FTP on the NAS and am able to access it from outside the network without any problems. I did notice, however, that whenever I connect via FTP it tells me that the server does not support non-ASCII characters. Which I think is odd since UTF-8 has been the standard for quite a while now.

I happen to have a substantial number of files with either Hebrew letters, or letters with accents and diacritics which FTP will not recognize and the transfer will fail (using Filezilla, but this happens with every FTP client I’ve tried, even from shell).

Now, I’m able to connect and login via SFTP/SSH but that TOO does not support UTF-8 files. However, when I log in to shell via SSH and set these environment variables:
$ export LANG=‘en.US.UTF-8’
$ export LANGUAGE=‘en_US.UTF-8’
$ export LC_ALL=‘en_US.UTF-8’

And I connect over sftp with user “sshd” the file transfer works out just fine. I don’t want to have to connect via SFTP if I can help it (and be forced to log in with the root user). Also, when the device restarts (as I have it power cycle once a week) - those variables don’t persist and I’d have to remember to log in again and run that command and then log back in via SFTP.

I’ve poked around the admin panel for the device and there doesn’t seem to be any config option to support this. This is really frustrating and frankly there’s no reason to NOT support full UTF-8. Is this something we can resolve? This is turning into a bigger issue than it’s worth.

Anyone can help? WD Support people, you reading this?

Hi shayaknyc

UTF-8 is supported by the FTP as well as SFTP but please check the settings of your FTP. I attache the whole FTP Settings procedure here to make it available to a wider audience. The 4th screen contains the client language setting.

Within the web interface, Settings -> Network, you find the FTP. After enabling the server, the “Configure>>” link can be clicked:

First page is maximum user limitation, Idle Timeout and Port (Port 21 by default, this should not be changed unless you know why you want/need to change it), Flow Control settings:

Passive Mode should be used by default to keep the FTP server on port 21, active mode will swap the transfer port to another, definable port (remember to use port forwarding in the router if enabled):

FXP at the bottom is File Exchange Protocol, please activate this if you want to transfer large files or want to copy internally from one My Cloud to another in the same network. This will speed up the FTP massive.

The Client language dropdown is what I want to point to:

Last page of the FTP settings shows the blocking capabilities, permant here:

or temperary here:

That’s the whole FTP settings dialogue.

Thank you for this, but I already have it configured exactly like this and every time I log in with the FTP client I receive the message that the server does not support non-ascii characters…