USB Drive not seen by My Cloud Drive

I have a 4TB My Book connected to My Cloud.  The drive use to see it not it doesn’t, any ideas?  I have tried re-booting the drive and tried resetting the drive, still does not recognize the My Book being attached.

have you tried connecting my book directly to a windows PC and run chkdsk /f

then mage sure you safe remove device via task bar

I had a similar issue and this solved it

Thanks Warlock777 but this did not resolve the issue.  PC can read files fine on My Book and chkdsk had no errors.

     >>>PC can read files fine on My Book and chkdsk had no errors.

If you’re using the exact same cable then you probably have a bad USB3 port on the My Cloud

Is there anyway to check, reset, repair the USB port on the My Cloud device?

there is a way but requires you know how to enable ssh(read the warning that it may invalidate your warranty) , install ssh (putty for windows or ssh in Linux etc).

first i recommend the following steps (my seem trivial, nevertheless we need to be absolutely sure)

login to dashboard

make sure the USB icon (top right) is grayed out. If it is not diconnect the usb drive and reboot. Wait till it settles down and you see the blue light.

Connect the USB drive and give it a minute  or Two to settle down and then check again in dash board.

if nothing attached do the following:

Login to mycloud as

user: root

password: welc0me <--- this is zero not o

from Linux ssh root@<yourdevicename OR ipaddress> 
Fill the information in putty if you are using it.
be very careful if first time (type the instructions exactly as shown here)

once you are inside


dmesg | grep usb >> dmesg.txt

<the output of this command will be saved in a text file called dmesg.txt)

to view the file type

vi output.txt

<use arrows/page up/down to navigate>

look for something like this:

[3499.489184] usb 2-1: new SuperSpeed USB device number 14 using xhci-hcd
[3499.509669] usb 2-1: skipped 1 descriptor after endpoint
[3499.515015] usb 2-1: skipped 1 descriptor after endpoint
[3499.520562] usb 2-1: default language 0x0409
[3499.525196] usb 2-1: udev 14, busnum 2, minor = 141
[3499.530134] usb 2-1: New USB device found, idVendor=174c, idProduct=55aa
[3499.536875] usb 2-1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[3499.544070] usb 2-1: Product: ASM1053
[3499.547754] usb 2-1: Manufacturer: Asmedia
[3499.551887] usb 2-1: SerialNumber: 0123456789ABCDEF0124
[3499.557476] usb 2-1: usb_probe_device
[3499.561220] usb 2-1: configuration #1 chosen from 1 choice
[3499.566812] usb 2-1: Successful Endpoint Configure command
[3499.572475] usb 2-1: adding 2-1:1.0 (config #1, interface 0)
[3499.578413] usb-storage 2-1:1.0: usb_probe_interface
[3499.583468] usb-storage 2-1:1.0: usb_probe_interface - got id
[3499.589551] scsi14 : usb-storage 2-1:1.0

You are looking for your drive, mine is called ASM1053 in this case and it is Superspeed (USB 3.0).

if it is not there then you probably have a malfunction.

exit the editor by pressing the <esc> key and type :q!

if it is there, check it was mounted and shared as follows:

cd /var/media

it should list the device there. To view the share do

ls /shares

it should list the device (and all shares).

if all fine then probably dashboard is malfunctioning (happened to me and I have to do quick reset).

I advice to go through the trouble shooting procedure in the userguide, if no luck then open a ticket.  Or you may prefer to open a ticket anyway rahter than go through this. Open a ticket from the help icon in the dashboard and tick collect logs and submit a ticket (this is the safest way).


Thanks Jamalaya, you rock!   Followed what you sent and it worked.  Thanks again!

Glad to hear that, You are welcome.