See but can't open


I can see my device (MyCloud3Tb) in windows file explorer but I can’t open it. I can click right and select “open” but nothing happens. I’ve tried restart an all te software from wd but nothing works.

pleas help

You’re posting in the My Cloud NAS forum, but you’re talking about a “My Book.”

Is that the My Book USB drive, or one of the My Book NASes (there are four or five of them.)  Please be more specific.

If it’s a USB drive, have you tried another computer?

sorry I meant “Mycloud”

I had that problem with a Vista PC until the drivers were finally installed.  I don’t think windows ever found the drivers it wasn’t until I installed the software from the website that I was able to access through explorer.

What are you seeing? Does it look like this? Is it under Network?

Posted by,
cat0w (USA)

I work on windows but I can only see my device in “network” and the problem is that I can’t enter it to see my shaers

I am looking at mine through my C drive and you are looking at yours under Network. Below is an image of what mine looks like when I click on Network and it shows all my devices.

Are you sure all your devices are in the same workgroup? See image below for My Cloud.

Posted by,
cat0w (USA)

the workgroup it also set right

but I’ve been using my device for almost a yaer now, it just append without any reason

Have you tried rebooting both the cloud and PC? I’m learning that the more things you add to your home network the more problems you get.
It could be that while your cloud was asleep or off another device took the router IP address you PC thinks belongs to the cloud.

I always recomend a static IP for any network resources. printers/NAS/servers etc avoids many issues

Any chance you’re experiencing this?:

it could be the overall_share issue

can you see the shares in the WD desktop app?

there will also be 2 icons in exporer, one for the DLNA server and 1 for SMB server, try both

if you can see them in the desktop app you should try a system only restore. leave data & shares in place. everything else reset to like new

I can see and acces all my shares when I use the app or de program of wd. I only have a problem with windows file explorer.

sounds like the overall_share issue, if you are pretty comfortable with Linux you can manually fix it or you can do a system only restore, this leaves all data & shares in place and resets everything else like new