My Cloud has stopped seeing attached My Book

Put this in the wrong forum before, so apologies.
I have a My Book attached to my My Cloud as additional storage, and this has worked fine for a couple of years with no problems., but a couple of days ago the My Cloud has stopped seeing it and it does not show on WD Discovery list. I have removed the MY Book and attached it directly to my computer and I am able to access everything normally, so what on earth is going on? I have spent hours rebooting everything including the hub to which it is attached via the My Cloud to no avail, getting really frustrated now, can anyone help?

Spent hours trying to fix this following various fixes on several forums but still the My Cloud cannot see the My Book, can anyone help?

I have the same problem all the time ! Especially if the power goes off. Would recommend putting it on a APC before you go through the trouble of getting it back up and running. It might take several times doing a hard reset 45 seconds. WD software on Mycloud is horrible

What firmware are you using on the My Cloud?
I recall a thread that 2.31.193 didn’t see USB drives and the solution was to install 2.31.183 from here

After many hours I tried your solution to use 2.31.193 and it worked. I did do a 40sec reset though, the device was just slow and not very responsive, I think maybe something had got corrupted as well, thanks for your help.

Sorry that should be 183