My Cloud EX2 Ultra cant see my USB 3Tb My Book Essentials drive

I have a WD My Cloud EX2 Ultra NAS on the latest firmware
2.31.149.

I recently bought a refurbished (direct from WD UK) My Book Essentials 3Tb drive.

The My Cloud can’t see the My Book at all, if I log in via the web portal only my existing WD Essentials 2Tb drive is shown.

I have reformatted the drive in NTFS (as I know the native format can be problematic). The NAS still cant see it.

Windows 10 has no problem seeing the My Book when connected via USB, but if I try to check the drive via ‘WD Drive Utilities’ (downloaded from here), the software cant see it and says ‘Attach a supported drive’, WD state it should be supported. I have googled the problem but got nowhere…

Is the My Book drive faulty or does it need a firmware upgrade, any suggestions, before I go down the returns route? I bought it specifically to attach to the NAS…

Many thanks

Patrick
UK

Sounds like a Windows 10 specific formatting issue.
Try formatting the My Book using Windows 8, 7 or macOS or a different Windows 10 computer.

WD my cloud ■■■■■ when it comes to plugging in a USB drive into it. In the dash board if you have the USB on turn it off cycle reboot then go back turn it back on and wait it takes a lot of time till it shows up under USB drives plugged in.

Thanks for the replies, unfortunately I am still no further forward. I previously had two WD 2Gb Essentials drives, both worked fine, then I had an issue with one not showing and found that the SMART flag had flipped, so that’s destined for the bin.

I bought the 3Tb to replace it, I have formatted it on Mac Mini as suggested using exFAT (which WD Support says is now supported ([here]).(https://support.wdc.com/knowledgebase/answer.aspx?ID=15124)), I also reformatted it in NTFS again on a different Windows 10 machine.

I discovered on the 3Tb that there was a protected UEFI partition that I couldn’t delete the normal way, so I used DiskPart to delete it following instructions on the web then reformatted the whole volume.

None of my efforts have worked. Any ideas?

Thanks guys

Patrick

@pgnl have you tried HSF+ or formatting on Windows 8.x or Windows 7?
Just wondering because I have an 8 TB My Book and when I format using Windows 10 on my Dell laptop, My Cloud never sees it. When I format using Windows 10 on my Acer laptop, it works. When I format using Windows 7 on my super old Acer laptop, it works. Both of my Windows 10 are the Home Version and all updated and patched.

Hiya, thanks for the reply and the suggestions. I have an old Win7 netbook sitting in a drawer so tried formatting using NTFS with that. Still doesn’t show in the Ex2 portal. Also tried reformatting using the Mac Mini in HFS+ (ie Mac OS Extended - which I believe is the same thing). Once again nothing…

The strange thing, obviously because the drive doesn’t show, I can’t correctly eject it from the EX2 portal, so I just unplug the USB lead. When I do that, the portal records that I’ve unplugged a drive without ejecting it. so it knows it’s there but doesn’t register it.

Any more suggestions?

Thanks guys