UPnP problems ! yet another problem!

I am starting to think this product is a total waste of time and money  :angry:

I am now having problem with enabling remote access and getting a relay connection on even though UPnP is turned switched on, on the router. it was working fine then just stopped.

Can anyone offer any advise??? i have tried so many things to get this product working like i feel it should.

Problem 1 - initial set up MBL couldn’t be found but that was down to AVG firewall so can’t really blame WD for that one.

Problem 2 - Can access files using the WD2go app on phone and tablet, but when thring to access via WD2go.com files won’t play and crashes laptop forcing me to hold power switch down to turn off. same happened to a friend when he tried accessing via his laptop.

Problem 3 - User don’t create correctly, when they sign in via WD2go.com they still have to enter system password which then takes them to the admin screen (not that is matters much with problem 2 as they can’t access anything)

Problem 4 - Now the UPnP problem.

Steps taken to try and resolve these. 

1 Asigned a static IP Address

2 Port forwarding

3 Put MBL in a DMZ on my router

4 Disabled ALL firewalls

5 Reset router to factory setting

6 Reset MBL to Factory setting

Apart from throwing it in the bin any other suggestions???


Seems if i remove mobile devices that sorts out the UPnP problem… but i see this as FAR FAR from a fix as what is the point of a NAS drive if you can access it remotely .