Remote access problem

Hi,

I have a MBL 2Tb, with Windows 7, and updated to the latest firmware.

Since some days ago I can’t access the drive remotely (wd2go or mobile). I went to the Dashboard and this is what I saw under Remote Access:

Captura.JPG

So ‘remote access’ checkbox is checked, but then it says it is disabled? any idea why this could be?

Thanks!

Sorry to state the obvious, but have you tried “Disabling,” saving, then re-enabling?

… or does it just stay disabled despite that and / or rebooting?

yes, I have tried disabling and enabling it again; and rebooting the device (via SSH), and it stays disabled

So you’re using MANUAL setup.

Are the port forwarding rules in your router still pointing to the correct address?

I have SSH enabled but never touched anything about the configuration there.

I don’t any port forwarding rules in the router regarding remote access (I do to access FTP remotely though), it used to be work fine without configuring anything, just enabling it on the website and the drive was accessible with my phone.

Well, that’s odd…   As far as I know, it’s required to make it work.  Otherwise the “Cloud” can’t get inside to get to the drive.

I noticed today that when I disable Remote Access and enable it again, for a brief second the message says something about ‘failed’ ‘error’ and a code, but it’s too fast to read it. Then it stays as in the screenshot I posted in the first message

Just for giggles, turn UPnP back on in your router, and set the MBL to “Auto” and see if it works then.

I haven’t found any option in my router dashboard about UPnP (it is a Motorola Netopia 7347-44, I didn’t find anything online either). Is there any other name this option could have? For example ‘port forwarding’ is the same as ‘NAT’ right?

By the way I got a reply from WD Support: Perform a Full Factory Restore (oh, surprise…)

Port forwarding is a part of NAT, yes.

This problem was solved by manually reinstalling the same version of the firmware I had. It was the only way to forma the system partition.

Apparently even a full factory restore does not format the system partition, I had a torrent client installed and it remained there after the restore.