MBL not connecting to internet

Hi all,

Just bought a 2Tb MyBookLive, latest firmware already installed, and after several attempts, I’m still getting error code 31520 (Cannot establish remote access connection).  Below is a list of what I’ve done to try and sort it out:

  1. Rebooted and tried shutting it down for a night.

  2. Self tested to see if that jogged it.

  3. Disabled OS firewalls and allowed all inbound/outbound traffic relating to the MSL IP through my routers firewall.

4. Attempted manual connection after reading about it in another forum, but I’m not sure if I did it right.  The router can see it is connected though.

  1. Reconnected the MSL using the disk after I couldn’t access it via the internet or My Computer; I can now access it as W:\ and use it that way only

I’ve not tried a factory reset or reinstalled the software on the disk as I’m pretty sure what I’ve not made that many changes.

Currently; it has a stable green light, I can access it via My Computer, I have updated the admin account and created a user account each with public and private folders, and that’s it.

I have Win7 64-bit Prof and my router is a Netgear (Wireless-N 150 ADSL2 + Modem Router) DGN1000.

Any help to being able to access the MSL remotely would be great!

Matt W

Matt, I have the same problem as you.with a 3TB .Same error code. Recognized on the Netgear router N900 but not in the network. Install with the cd does not recognize the drive, install with the file says to update firmware…firmware is up to date but still no install possible… I did a hard reset on modem router, Netgear router and left the drive off all night…Still nothing.

Discovered the problem after I downloaded a movie and could not find it in the library, just on the computer. Now the drive, even though correctly connected ,seems to not exist…

Let’s hope someone can offer a solution soon :slight_smile:


Ok, I left it over last night after not doing anything to it and it now says that it is connected to the internet.  However, its saying its a relay connection and that I should enable UPnP on my router… the thing is, UPnP is enabled.  The connection speed is terrible at the moment so any help to solve this problem would be great.



almost everyone whom have installed the latest FW is experiencing Remote Access issues.

as for your local shares issue, you may want to try a factory restore. - do note that factory restore erases your data, thus remember to do a backup.

Thanks for your post.

Is the remote access issues with firmware version 02.11.09-053? because thats what I have.  I should of clarified it in my first which one I had.  My apologies.


the affected FW should be 02.32.05-044 which is released on (9/5/12).


Had the exact same issue on both my MBL and MBLD … 31520 across the board. Gave up late night before last and out of a whim it was working again last night. I haven’t fiddled with the UpnP settings, but figure as long as it’s running, I’m happy.

The curious thing is that the exact same error showed up on both my devices and a friend’s MBLD, which I had installed last week. Hers works now, too, without any intervention which begs the following question: does the authentication process for WD2go go through some WD infrastructure that might have been down? If so, is WD watching or even accessing our devices? I’m certainly no conspiracy theorist, but just curious…

I know, bizaar isn’t it.

Im still having issues with remote connections, slow connection speeds as well hanging when transfering files and even completely crashing.  I submitted a help request and will let people know what comes of it.  I certainly did not expect these sort of problems with such a purchase but hopefully they can be resolved.


So yours is working again, too, albeit with some speed issues?

I’ve gotta say, while I wasn’t a big fan of WDs external disks, I am very pleased with their NAS products (OK, apart from these recent issues). I’ve also bought a MyBook Thunderbolt Duo, which is brilliant, if a little pricey.

Please do share what you find out from WD’s tech support.