My Book Live 2TB Network Drive Remote Access does not work

Very disatisfied with my purchase of the My book Live 2TB External Network Drive.  I purchased this piece of junk about a week ago. I hooked this drive to my wireless router, connected the power and ran the setup disk.  Computer discovered the drive and mapped it for me. The drive itself, just like any other external hard drive, stores data just fine.  It is when I went into the My Book Live website that I noticed the problem.  WD’s website as well as the packaging promise you to be able to hook this drive up and you will be able to remote access it from anywhere in the world. [Deleted]  I go on the website, select Settings and then Remote Access. Boom, ERROR - 31550 - Internal Server Error. Please retry your last operation. I click the Enable button, as per the instructions, ERROR - 31505 - The device status could not be updated due to an communication or internal software error.  My Connection Status: Failed Cannot establish remote access connection. Make sure you are connected to the Internet. (Error 31520). And yes, I am connected to the Internet and it even shows this on My Dashboard.  I figure I must have a setting wrong somewhere and I will just come back to it when I get the chance.  I start to put files on the drive, about 280 GB in the last few days alone.  I am coming up on a business trip, so I figure I will do a little research and try and figure out this problem before I fly out so that I will be able to pull files off my drive while I am out of the country.  I get nowhere fast trying to read through the mountain of different instructions listed on WD’s website.  I call the “Concierge Service” number that came on the box…Concierge Service…hmmmm…if I had to rate this concierge service like a hotel I would have to say it felt more like a cheap Motel 6 at the corner of Compton and Normandy.  After being on hold for thirty minutes, I finally get a hold of an individual.  He tells me the only way to fix the problem is to perform a full factory restore on the drive, erasing all the data I have already backed up.  I asked if there were any other way and he assured me that there was not. Are you kidding me? No questions about settings on my router, drive or computer???  Just perform a factory restore?!? I will be **bleep** if I am going to copy over all of the files, 280GB, I have on the drive back to another drive, which would take approx 16 hrs, perform a factory restore and then take another 16 hrs to copy them back.  How about instead I just never buy another **bleep** WD product ever again and I inform all of my family, friends and business colleagues to follow suit.  Besides, what is a factory restore really going to accomplish.  This was a brand new drive straight from the factory and it didn’t work then and I am sure it will not work afterwards,  EVERYONE READING THIS, DO NOT BUY A MY BOOK LIVE DRIVE UNLESS YOU ENJOY HEADACHES!

There are other alternatives for remote connection

you can try FTP

Did you upgrade the firmware yet?

So you tried it, it didn’t work, you went ahead and filled it with files anyway, expecting it to work without any problems later on? And now you’re mad because you have MOVED files to a drive which you KNOW you can’t access from the outside? I’m sorry, but that’s all on you.

Buying products from another manufacturer won’t help you in any way whatsoever. You might consider keeping backups of your important files and start approaching your technical devices as you would anything else that you own. I mean, you wouldn’t go on a one week vacation with your car if you hear the gearbox making funny noises, right? And you wouldn’t start painting your whole house right away, rather start with a small part of it to make sure the colour actually matches what you ordered, right? And you wouldn’t let the locksmith leave your house having changed your locks if the key doesn’t fit, thinking “it probably just needs a good wiggle, I’ll try it later”, right?

Tried a firware update.  Firware is already up to date.

exact same problem here mate,

ive just bought a mybook live 2TB and installed it on my wifi router, all is ok and i can access it no problem from any computer on my network.

2 problems ive got so far are :-

  1. itunes wont load up my shared music file from NAS, it just constanly says loading

  2. I try to setup my remote access via the installation CD but it constanly tells be i have an internal server issue and cant do it, these are the 3 main fault codes ive had

     32111 - failed to crete user account

     32102 - internal server error

     30000 - network connectivity issues

hope you guys can help


The installation CD has no bearing on Remote Access.   There’s nothing to install for WD 2go.

The install CD you have *might* have the MioNET software, but that software is no longer used since Mio was replace with WD 2go in later firmware.

ive managed to sort out the constant error msgs from setting up the remote access by doing a full factory reset from the WD dashboard, all works like a dream now!!

Still got the itunes issue though, just shows as ‘downloading’ on the main screen.

any advice would be great but please be aware im a complete novice at this so step by step instructions & explanations would be great.



Dont know if this is any help. I set MyBook Networkmode as Static and applied an IP. Found the MyBook on my router an did the same - static and (same) IP. Result = no internet access. Kept the static settings on my router and changed the Networkmode setting on MyBook to DHCP. Bingo = internet access good

Interesting comment draz63 … possibly, this was the fault I hit as well.

I had fixed IP in MBL; noticed that I had no Internet Access; couldn’t fathom out why, so in the end I did a factory reset after which Internet access good … however, what I haven’t done YET is to set to Static IP within MBL, only in router.

So possibly I had the same issue, but thought it was a general corruption … certainly not going to touch the DHCP setting now in case I break it again!

I wish I didnt buy this piece of junk. Very difficult to get remote access to it via the wireless router, the link got broken all the time.

The worst thing is it got crashed few weeks after I bought it.

Bought it to the service centre for repairing but they dont fix it in Singapore. They had to send it to Malaysia and I got back a new unit with all the data lost.

The new unit also has problem with connection.

Just Connected it directly to my laptop and still cannot get access to it. [Deleted]

if the link keeps breaking, trying reserving a single dhcp address for it in your router.  Or, setting it to static IP.  If your router has a short lease time it might be assigning a new IP frequently and the dNS might not be keeping up.

Dear All,

I have the same problem but I cannot solve also fixing settings on my ADSL router. Can somebody help me?

I have to ask: why didn’t you make sure the thing worked before you uploaded all those files?


Currently my MBL has 600GB, I do have remote SSH access, as well as DDNS set on my router. Mobile apps work fine as well.

HATE IT!  My 1TB My Book Live is also a piece of garbage…doesn’t connect remotely, 2 years later - never has.

Called about it once, twice, three times…all they want to do is reset the thing and try to make you lose your data.

Now it’s super slow and makes a lot of noise…takes almost 5 minutes to display a folder with lots of files in it…it’s practically unusuable at this point. I’m looking forward to having the money to replace this unit with something non-WD.

Don’t buy any WD equipment! You’ll end up being sorry if you do and spending most of your time talking to folks in India.

Well I wanted to delete the comment that occupied this space initially, but of course, there is no delete option. (thanks again WD)…so instead I just edited it and typed this to you all.