Upload speed from the NAS is very low

Hi there!
My current internet connection provides an upload speed of about 10Mbit/s. This works reliably, checked the upload for example from Mac to Dropbox -> 10 Mbit/s.

But do I try to download pics or a video file by Cloud access via internet from the NAS towards another device then there is only an upload speed from NAS of 1 or max.3 Mbit/s. (Checked it parallel in the info box of my router). The client and it`s Wlan connection, in this case the Ipad, is not the issue: downloads from other sources are possible with 30-50Mbit/s.
Nethertheless, the download from the NAS, proceeds only with mentioned 1-2 Mbit/s. This very low result I also get when I acces onto the NAS via a privat VPN tunnel… it works but also very slow…

Any idea how tho fix this situation? Why the EX2 Ultra seems to generate only such week upload speeds? Any advice was welcome!

If this is not the device you own, then you posted in the wrong place. Go back to WD Community and look for The EX2 Ultra.

First of all is there any devices connected in between.

As per explanation it seems you are trying to download from Internet mycloud.

If it is so then you have to check what is the speed of the device you are connecting to mycloud via internet outside your home network.

Are you also implying that internal upload is read speed via portable devices are less than rated speed.

but here you more of Internet speed issues. Then you have to be sure that router utilization at the time of your requested file transfer . if other devices are connected then it might slowdown. As both Upload and download traffic cant be same.

@DirtyMacho
Thanks for your advices - yes, I`m absolutely aware about all this details up-/download/internet speeds of the receaving client (an Ipad) and the sending EX2Ultra. Tried to explain it in my first post - but maybe my english might be a problem.

Again, I checked and measuered the following speed datas in PRACTICE ( not theoretical):
Reading speed EX2: about 60-100MBYTE/s
Available Internet UPload speed (for the EX2): 10Mbit/sec
Available download speed for receaving Ipad (Wlan): 30-50MBit/sec

So, in this constellation the bootle neck would be the limited internet UPload for the NAS of 10Mbit/sec. Again: checked it in different ways, for example dropbox upload - it IS available indeed.

But: do I try a download on the Ipad (in a separate Wlan via VPN and/or WD Cloud service) I would expect at least a transfer speed near the 10Mbit/sec, the slowest data speed in this transfer chain. Was satisfied also with 5…10Mbit/sec - but not with very poor 1-2 Mbit!? This is only a tenth of the lowest link in the transfer chain!

What I expected is to have enough transfer speed for video STREAMING via internet. 4…10Mbit/s were quit ok. for this with my video files, so my internet connection for the server (NAS) was capable enough for this

  • but with resulting only 1…2 Mbits it`s stuttering to much…

Now coming to the router part. Do you have QOS setup on the router. Was this device in the highest priority.

Share more on how you connect to router.

You tried to measure the speed by which means

Checked possible download speed on Ipad by different speed test apps.
Checked my possible internet upload speed by uploading a sample file to dropbox. Checked parallely the real upload rate in my router (fritzbox).
EX2 is connected via GigabitLAN to the router. The ipad is connected via Wlan into the “guest net” of my router - so that it has to go via internet for accessing the NAS.

I`m going to check my QOS settings in the router. Come back with information.

Checked the QOS settings in the router. There had been no priorities, so I set a priority for the NAS.
The following test has shown me, sorry to say, no positiv changings:
Saw again max. 2 Mbit upload… parallely to this I initated an upload to dropbox - and immediatly I saw 2+8 Mbit/s upload … so full available upload rate, but only 2Mbit`s used bei the NAS… :neutral_face: