Upload from PC to My Cloud Home is very very slow

Hello,

I recently set up my My Cloud Home and putting my files on it. I installed WD Discovery and have it mounted as drive Z: on my Windows 10 PC.

I noticed that the upload speed seems to be capped around 18 MB/s, which is very slow when you’re transferring 2 TB+ of data.

My network setup is below. I’ve checked all connection status on my PC and on router and I’m getting full 1000/1000 (Mbps) from PC to switch, switch to internet router, and internet router to My Cloud. I have tried rebooting the My Cloud.

Any suggestions / help please?

Hello,

Please refer to the following KBA article: https://support-en.wd.com/app/answers/detail/a_id/15542

Hello,
Thank you for getting back to me. I’ve run through the support link you sent me. To check this off top to bottom:

  • I think my network diagram shows I’m not having issues with the first 4 points (I can show screenshots of my PC and router status showing Gigabit connections across the board if you like)
  • I’m only using a single other app on the My Cloud which has a monitoring feature to show traffic (it’s at 0 when I tried my various uploads).
  • I use Panda Dome for AV which has no known issues with My Cloud. I did turn it off, rebooted, and tried again but it made no difference
  • No password protected shares or folders
  • This occurred with both a large set of folders (~1TB) and individual files (1-2GB)
  • Folders not deeply nested, and files are all video files (so not millions of small ones)
  • How would I see if My Cloud / DLNA / iTunes is transcoding anything? I don’t use DLNA or iTunes

Regarding theoretical speeds - I think my upload speed of 18MB/s does show that I’m getting slightly faster than 100 Base-T, so Gigabit is enabled and working. But I’m getting well shy of your realistic averages of 30-60 MB/s

  • Network config: As outlined in my diagram, I’m using the “good performance” option
  • Client system issues (64 bit computer, 16 GB RAM, computer not doing anything else, SSDs don’t get fragmented, and I already covered AV, Data structure is large files not small, and I’m not using USB cables. It’s a desktop PC so no standby issues and sleep is disabled on my PC)
  • Network layer: I get my full ISP speed usually (though this should not matter for local uploads right). I’ve already covered that I’m using 1000 Base-T network. I’ve kicked all other devices off the network so there’s no other interference. I’m not using a network hub and firmware is up to date. Not using Wi-Fi.
  • My Cloud Home issues: I don’t use USB. I don’t know what WD Sync is but I don’t think I use it. I just use WD Discovery to map it as Z: Drive so I can upload from my PC. Data transfer - your article refers to content indexing and thumbnail generation. Can this be disabled? I don’t want the drive to do this - I have an app for that if I want it.

Sorry for the long list but it was a long troubleshooting link and I did want to be thorough. Please do let me know if there’s any additional information I can provide to assist with troubleshooting! :slight_smile:

I see that your PC is on 192.168.1.0 and your wdmycloud is on 192.168.0.0. I’m assuming these networks are /24 bit masked (so netmask of 255.255.255.0). That means you’re routing between networks which could account for the performance loss, especially if it’s happening on a low power router.

Have you considered flattening your network?

Another test is to plug the wdmycloud into the same switch as your PC and see how that goes.

Hi mstargard,

I did expect someone to suggest this but I’ve given it a shot anyway just to make sure. It’s made no difference whatsoever. Below you can see a screenshot of my router connected devices. WiFi is off. This is just my PC and the MyCloud Home (and a smart home device):
image

And here you can see my upload speed:
image

So I think that removes any concern about the subnets or too many devices.

OK, I’m seeing both your PC and your mycloud on your wireless router in the 192.168.0.0/24 segment.

Suspecting that the router is the source of the problem, try putting your PC and your mycloud on the other switch you’ve got - the one you’ve labeled as 192.168.1.x network in your original diagram.