Upgrade to OS5 on MyCloudMirror Gen 2

I tried to upgrade today from 0S3 to 0S5.
Afterwards, when trying remote access Firefox tells me there is a problem loading page and can’t access the drive now.

I have tried to phone WD Support without success. Does anyone have a valid telephone support number. I’m in UK

. . .and the horror show begins.

The issue is “indexing”.
The MyCloud Mirrors don’t have enough processing power for both indexing AND allowing user access.

The cure is, if you actually manage to gain dashboard access is to turn off cloud services. That will stop the indexing task.

The other option is to wait for indexing to finish. Won’t take more than a few days or a couple of weeks for larger units.

(root cause: The indexing process is HORRIBLY inefficient, and this device is on the slower side)

1 Like

Thank you for that explanation regarding the “indexing”. After migrating to OS5, my My Cloud Mirror Gen 2 has been indexing for a week. It takes several minutes to access the dashboard. I have accessed it about three times this week just to see the progress. The unit just runs and runs and runs. I recently joined the forum specifically to post this questing about the indexing issue. Now I know it’s not just my device. Maybe in a few more days, it will be finished.


Don’t upgrade, its rubbish, ive been indexing for over 2 months, 6TB mirror. So not able to use until its reached 100%

2months plus and at 67%