Unknown Problem: rsync issue or firewall issue?

Got myself a brand new EX4 to replace an older NAS. After updating my firmware and setting it up, I used rsync to copy all of my old files over. Now I have problems and I can’t tell if they are related to the rsync process, my firewall rules, or both. Here are my symptoms…

First, if my PC/mobile device is on the same LAN as my EX4, I have no issues (makes me think it is a network issue).

When I connect ‘remotely’ with mycloud.com or the mobile app, I am able to see the folder structure I created, but none of the files I copied over. If I go back to my LAN and upload a file, and then go back ‘remote’, I can see the file (unlike my rsync copied files). When I try to open/access that file, it is not readable (makes me think it is a permission issue).

Thinking it was a permission issue, I SSH-ed into the EX4 and looked at the file owner, group, and permissions. I duplicated what I saw for the uploaded file and made everything owned by root (chown root), in the root group (chgrp root), and full 777 permissions (chmod 777). Even after that, I still have the same problems.

I decided to try using a different set of network ports (not 80 and 443). I set up a static IP, and went into https://ex4 > Settings > Cloud Access > Cloud Service > Configure. I changed the external cloud service ports to 5080 and 5443. I then changed my router to forward all external-to-incoming traffic from 80 and 443 to go to my EX4 on 5080 and 5443. Again, no improvement in my situation.

Anyone have any suggestions on what the problem may be, or even just suggestions on what to do next?



I have never tried this before. Lets see if another user has tried this before and can share some experience on this matter.