Intermittent problem accessing EX4

After several months of smooth operation, over last couple of weeks keep encountering a problem. When copying a large volume of data (50 - 100GB) from My Cloud EX4 to a computer running Windows 7, the copy process would randomly issue an error message saying “There is a problem accessing MyCloudEX4”, “Make sure you are connected to the network and try again”. Pressing “Try Again” doesn’t work however pressing “Skip” resumes the copy immediately. The MyCloudEX4 and the computer are both cable connected to a Linksys E3200 router using gigabit ports. Have already tried changing ports in the router, even went thru full restore of the device , no luck.Working the other way around there is no problem and even a 600GB backup from the same computer to the EX4 runs successfully. Device is loaded with 3 x 3TB Red drives set as RAID 5. No configuration changes to the network were made recently. Please advise


Are you using the drive with a static ip or DHCP?

Does resetting the unit make any changes? If you have try that, please do so.

@ERmorel, thanks for the reply

Using DHCP since added the EX4 over a tear ago, no issues until couple of weeks ago.

Tried full restore however without change

A few inputs after more trials:

  1. Copying the same folder using WD My Cloud app works fine, unlike copying using Windows Explorer that results in the error described.

  2. Tried to copy the same folder to two different PCs, both running Win 7 64, both generated the same error however on different files. Seems like error appears randomly

  3. Have an older 4TB MyCloud on the same network and do not encounter the same problem.

Wild guess - can it be related to my local network in any way. Maybe the copy from EX4 is faster than all other directions and hits a bottleneck on my network? If this is a valid idea, I have no idea where to start.

Update after receiving inputs from WD support and running several more tests.
Updated to recently released 2.11.133 firmware and performed (another) system restore.
Good news - so far seems things are back to normal
Bad news - no idea yet what triggered the problem

Thank you so much for posting problem and resolution AmiZiv. I was ready to pull my hair out. Swapped cables played endlessly with network settings, purchased switch. Same problem as yours and resolution worked perfectly.

Many thanks,