Problems copying files to my EX4

I am attempting to copy a large amount of data from my laptop computer to my EX4.

I am using Windows 7 on my laptop. My laptop is connected to the network via WiFi. The EX4 is connected to a gigbit switch which is then connected to the WiFi router.

I have tried several options to transfer files to the EX4, here are my attemps and my findings:

Windows Explorer: Just open Windows Explorer, hit Network, double-click on the EX4, navigate to the folder I wish to copy files to. Open a second explorer window and navigate to the source folder, and drag-drop files to the EX4. For small numbers of files or small files (might be related to the amount of data transferred?), this seems wor work OK but it is rather tedious when I have ~400GB of data to transfer and can only do it one folder or two at a time. I certainly can not get it to reliably transfer 8GB of data, and usually it stops at less than that. What happens is that at some point during the copy process, I am presented with an error that the network location is no longer available. Nothing works to retry and resume, so I have to cancel and start over.

TeraCopy: Using the Windows Explorer source / destination windows as described above, I right-click on the source files, drag and drop on the destination and choose TeraCopy here. That will usually result in transferring a few more files, but in the end I get the same error message and have to start again. Although TeraCopy has some added functionality to keep from transferring the same files multiple times, it can take several tries to complete the copy process for any given group of files.

WD Cloud application: This seems to have slightly more success. Although it won’t work for overwriting existing folders. I have noticed though that during the copy process, it will appear to stop transferring files for a short time, then it will pick up and continue. I think it is during these pauses that Windows Explorer and TeraCopy are having issues with the connection to the EX4 being reset or something like that. Almost as if the EX4 goes to sleep, and when Windows gets tired ot poking at it to continue to sending files, Windows gives up, but the Cloud program seems to just wait for the EX4 to return and continue where it left off.  But because this application won’t overwrite existing folders, it’s very difficult to copy files / folders to the EX4.

Does anyone have a recommendation for what I can use to reliably transfer files to the EX4? I’m not worried about how fast they transfer. I would just like to be able to select a group of files / folders, click copy and walk away knowing that it will get done.

Have you disabled your NAS’s sleep timer? And how many files are you trying to copy? A single 4GB file will be copied significantly faster than 4,000 1MB files. 

Sometimes I try to copy a single large file, 4-6GB, sometimes one that is 24GB in size. And sometimes I try to copy large numbers of files.

The NAS is not going to sleep. I disabled that some time back, probably shortly after I first got it.

What I saw was that it would get a portion of the way through a large copy job and then fail.

I ended up using a program that someone else on here said they use, called fastcopy and was able to get the copy completed. However, when copying my pictures from my old laptop to the NAS, it did fail at one point. However fastcopy was able to continue and pick up where it left off to complete the job.

I just don’t understand how the NAS can ‘go away’ for lack of a better term, when it has a static IP, and data is in the process of being sent to it. It is almost like it just mentally gets lost in the middle of a sentence, and then has to come back to reality to let the job complete.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country