Unbrick mycloud 1 bay gen 2

Hello @Fox_exe- Thankyou for your response.

I am confused, if i erase the first 10 GB and when I will recreate the partition it will pick the erased partition as well, isn’t it?

The purpose of doing the erase. Is to overwrite the current partition table. So that it can be recreated when you run the part command. In the hopes that there was something in the table causing the problem.

Hello @rac8006- I Have formatted the complete drive in windows then start making those partition stated above.

i did exact same thing mentioned above.

It’s more for delete info about partition’s (Disk UID, Raid partitions UUID’s and etc).
Plus - it’s for complete erase file’s data (When you delete partition or file/directory - you, actually, delete only info about it, not data inside. In theory - its possible restore “info” part of file over these data and get original files (And configs))

Yes @Fox_exe- I did what you suggested but still no luck.

i ran the command on whole disk and it gives me below output

dd if=/dev/zero of=/dev/sdb bs=1M count=10000
10000 records in
10000 records out
(10 GB, 9.8 GB) copied, 10424 s, 6.5 MB/s.

then i ran below commands:

parted /dev/sdb
mklabel gpt
mkpart primary 1049kB 2149MB
mkpart primary 8591MB -1MB
mkpart primary 7517MB 8591MB
mkpart primary 2149MB 3222MB
mkpart primary 3222MB 4296MB
mkpart primary 4296MB 6443MB
mkpart primary 6443MB 7517MB
mkswap /dev/sdb1
mkfs.ext4 /dev/sdb3

mkdir /mnt/boot
mount /dev/sdb3 /mnt/boot
mkdir /mnt/boot/boot
cp uImage-wdrecovery /mnt/boot/boot/uImage
cp uRamdisk-wdrecovery /mnt/boot/boot/uRamdisk

Then i unplug the disk from USB and attached to WDMC, open the IP in Browser uploaded the latest Firmware file “My_Cloud_GLCR_2.31.204.bin”

but still it is 0% from Last 90 Minutes.

Hmm… Try older firmware?

Still No luck, it’s on 0%.
do i need to map the USB as well with Recovery files on it?

A suggestion as a troubleshooting step. Try using a Windows PC to create a single partition covering the entire disk, then format it for NTFS. Then try running through the unbrick procedure for the single bay gen 2.

I found that in one strange incident on gen 1 single bay that one specific hard drive for what ever reason wouldn’t properly unbrick unless I partitioned and formatted it on a Windows PC first. Probably related to what Fox_Exe is suggesting above to erase the initial sectors/space on the hard drive. In my case I had to partition the drive to MBR not GPT and format it for NTFS. Then use Linux to repartition and format per the unbrick instructions. Not sure why only that one hard drive was problematic but it was.

Thanks mate, let me try that and get back to you.

one thing i need share, after making partition when i press “q” to quit. i get below

Information : You may need to update /etc/fstab

Still, No luck, tried with older firmware and ran all commands as suggested.

still on 0% from last 2 hours.

Lets step back here. What directions are you using to unbrick your second gen My Cloud?

If following these directions: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_en.txt Are you using the first method or the alternate method?

Rather than trying to upload the very latest v2.x single bay My Cloud firmware try using an older version as a troubleshooting step if you haven’t done so already.

i am following the alternative method from above article and using the very first firmware released “My_Cloud_GLCR_2.10.302.bin”.

Alternative way:

Use Debian/ubuntu or any other linux distro (USB/CD Live image)

All “/dev/sda” change to your disk! (List disks in system: “parted -l”)

If this is new disk or damaged (formatted) old, recreate partitions first:

Typically message means that one may have to restart their Linux OS PC so that the Linux OS will properly see and uses the newly created partitions on that hard drive.

Other troubleshooting suggestions. Use GParted within the Linux GUI to remove all partitions on the hard drive. Then use GParted to create one single partition. Then when following the unbrick steps use “parted” to remove all existing partitions first, then follow the steps to create the required partitions for the My Cloud OS structure. Also as a troubleshooting step, remove any other hard drive attached to the PC other than the My Cloud drive to avoid any possible issues. Check the drive for SMART errors or physical errors.

Not sure it’s been asked but what hard drive are you trying to use to perform the unbrick procedure on? In other words; what make/model hard drive will be put into the My Cloud enclosure? Wonder if the issues you are having are specific to only that drive. Don’t recall anyone having such issues repeatedly while unbricking using Fox_exe’s directons using either the main 2nd gen unbrick method or the alternate method.

Hi @Bennor- I am using the WD NAS drive which comes in My Cloud.

i have checked it doesn’t found any errors.

let me perform the steps suggested by you now.

i just noticed that after making partitions in Gparted all partitions are showing as unknown, do i need to format them before i assemble in WDMC:

@Jorawar, something wrong. Partition 3 must be formatted in Ext3 (or ext4) format and contains “boot” folder with uImage and uRamdisk files inside.

When following the alternate direction steps, have you performed the following step after quitting mkpart where indicated in the alternate directions steps? Example using your /dev/sdb layout:

mkfs.ext4 /dev/sdb3

The mkfs.ext4 step will format /dev/sdb3 as EXT4. From there you can copy, as the directions state, the appropriate files to folders you create on that EXT4 partition.

Per your screen capture it appears you have formatted the wrong partition for EXT4. Your screen capture shows partition 2 (/dev/sdb2) rather than partition 3 (/dev/sdb3) being EXT4.

@Bennor @Fox_exe - I followed below Link and i am able to unbrick my disk:

i was following Fox’s method but it doesn’t work, so just concern when we create the partitions do we need to format the other partition to some specific format?


because as per Fox’s method we are only making SDB1 as “mkswap” and SDB3 as “ext4”

might be the it is causing the issue as other partition are “UNKNOWN”

should i format the partition to specific format before putting it to WDMC and Boot UP?

@Bennor @Fox_exe-

I am able to unbrick with above link, but getting below issues:

1 Not able to Make Static IP
2 Not able to Change Drive Name
3 Not able to Change admin user name.
4 Not able to access the drive over WD My Cloud app or web portal.

as soon as i reboot, it turns back to default.

@Fox_exe- Please confirm, with your method do i need to format the below partition before booting up with WDMC?