Unbrick 3TB Gen-2 - Help needed

Hello All,

I have a WD Mycloud, model WDBCTL0030HWT-10 which I have not used for some time after having problems using it. Now I have decided to try and put it back into use. It’s a 3TB unit and I believe it’s a Gen-2 version.

All this week I have tried the various unbricking methods I could follow on the forum to resurrect the unit but have failed miserably; always ending up with the blue flashing led.

I’m a complete novice to Unix but have managed to create a Unbuntu bootup memory drive.

There is no data on the 3TB (WD Red Drive) having been formatted ready for a fresh installation.

Has anyone a Gen-2 image file that they know will work or a method they know that does.

Many thanks

Are you saying you formatted the drive? Did you replace the old drive with this one?

How long did you allow the blue LED to blink?

Use the following link and read the User Manual for your generation of My Cloud. For the second generation see Chapter 2, LEDs.

https://support-en.wd.com/app/products/product-detail/p/126

Hello cat0w,
Yes I reformatted the disk. Long story but I lost communication with the Mycloud and nothing I could do at the time could re-establish a connection. I tore it down and used DiskInternals Linux Reader to grab as much of the data off the drive that I could which was quite successful geting back about 80% of the data.
It’s been sat to one side for at least 6 months untill last week when I decided to try and resurrect it.
One of the programs I tried was to re-image the drive after seeing several postings claiming sucess so intially ran the format prior to loading the image.
With regard to the blue flashing light it remains flashing for as long as the power has been applied but generally I power down after 30 mins has elapsed.

The following post looks like it may have the solution.

[My Cloud Gen2] Using an 8TB HDD and Formatting Failure (Error Code: 600)]([My Cloud Gen2] Using an 8TB HDD and Formatting Failure (Error Code: 600))

Regards

This looked promising with mcmetrox having successfully restored his drive that I decided to give it a go.

  • 3TB RED WD drive for a Gen2 MyCloud (My original drive)
  • Ubuntu and a usb3.0-to-sata HDD adapter for preparing the drive.
  • 1GB memory stick containing the Boot folder with the wdrecovery- files.

I followed the instructions as given here and used the #alternative way.

_unbricking_en.txt The instructions on how to unbrick

usbrecovery.tar.gz The Gen-2 boot files.

Code used as in attached pdf.

After completing inputting the code my Gparted table appears to very closely match that shown in mcmetrox’s Gparted table as in his post.

My Disk

Next the circuit board was reassembled onto the hard drive and the ethernet and power cables plugged back in. The blue flashing led remained flashing and does not change.

Any help or advice from someone who has successfully restored their unit would be appreciated.

Fixing Gen2 Code.pdf (85.3 KB)

The light will flash until you complete the second part of the setup!!

You have to log into the device over the web interface. It will tell you something like “Hey, it looks like your firmware is corrupt, please point me to a valid firmware file” with a browse button. Point it at a valid Gen2 firmware, and let it do its thing. It will install the firmware then reboot.

After reboot, you have to do stage 3:

click on the “storage” tab, and set up the disk as a JBOD with a single disk. It will perform a SMART self-test on the drive, and if it passes, it will ask you how you want to configure it. Just pick all the defaults. It will partition the device, then reboot again.

THEN you are done. :smiley:

Many thanks Wierd_w for your kind assistance.I would be extremely grateful if you could explain a little further what the second part is.
I have “Fing” for my mobile phone which shows the IP addresses of the equipment connected close by but it does not show the WD Mycloud or any IP address for it so I’m unsure of how I can connect to it.
I would really appreciate your help further.
Kind regards

After you applied power to the My Cloud did you do this (last) step as indicated in the Alternative Way?

After few minutes WDMC boots to “WD Recovery”. Go to webgui and upload official firmware.

If you do not know the IP address of the My Cloud, access the local network router (or DHCP server) and see what IP address it has handed out to the My Cloud. Input that IP address into your web browser to get the recovery page that should allow you to upload the latest official My Cloud firmware. You will need to download that firmware (.bin file) ahead of time if you haven’t done so already.

Firmware Release 2.31.183 (05/20/2019): https://download.wdc.com/nas/My_Cloud_GLCR_2.31.183.bin

Hello Bennor,
I think this is where I am stumbling. If I access my router “Sky Hub” and look at the list of attached devices there are only two with their IP addresses listed. One is for my attached NAS drive and the second is for the laptop I am currently using. I believe that the MyCloud for some reason is not communicating with my router.
Many thanks for your patience and advice.
Regards

Just to understand, you have a second NAS device on the local network? Is it another My Cloud device or some other manufacturer’s NAS?

One suggestion is to disconnect the second NAS from the router/Sky Hub. Then power off the router/Sky Hub. Power off the computer. Power off the My Cloud. Wait a few minutes and power on the router/Sky Hub and wait for it to boot up. Then power on the My Cloud. Wait several minutes, then power on the computer and see if you can reach the My Cloud. Other troubleshooting steps are to replace the network cable between the My Cloud and the router/Sky Hub. May not do anything but try doing a 40 second reset as well using the reset button on the back of the My Cloud.

Hello Bennor,
Sorry, I should have made it clear that the attached NAS drive was a Synology NAS drive that I bought to replace the WD drive when it went down.
I’ll try the methods you suggest and will update on completion.
Many thanks
Kind regards

We’re you ever able to fix this? I am not able to connect to mine via Ip either and have spent so much time getting it back up with no luck either. Wondering if you had any success?

Hello,
I was totally unsuccessful and finally removed the hard disk and put the rest of the unit into the bin.
I bought a Synology single bay unit and fitted the hard disk into that.
I have since updated the Synology to a two-bay unit and have never had any issues with it.
Synology also provide so much free software you can use with it.
Sorry I cannot help you.