My cloud gen2 fix by fox_exe ends up blinking red and no safe mode

hello,
My mycloud was becoming difficult to operate to the point I only had access and no way to add or delete files yet was logged in as admin.IT had the blue light flashing issue for days
So I decided to try and unbrick it using the tutorial by Fox_exe but now its stuck blinking red. Only access via telnet, can I be helped please. Offering some coffee,seriously desparate to save my data

Which tutorial by Fox_exe did you follow? The one for the second gen v2.x My Cloud?

https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_en.txt

Did you use the main method or the alternate method? If one doesn’t work, try the other method.

Have you tried running the unbrick process a second (or additional) time?

With his first gen directions I sometimes have to run the directions more than once before it works right. Also its important not to change any of the values when running the mkpart commands to create the needed partitions on the hard drive.

Wow looks I got the wrong text file. I was following a youtube vid on that page…So I guess I have to format my drive :sob: Please is there another way without formating hard disk

If the My Cloud hard drive is still accessible using Linux then copy the user data to another location first. Then proceed with the unbrick process.

This means what actually… I install linux …will Ubuntu work? And do you have working Link am suspecting that maybe the file versions I have are messing my fix attempt

User Fox_exe repositories:
Main Repository: https://fox-exe.ru/WDMyCloud/
Second Gen: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/

Second gen directions:
English: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_en.txt
Russian: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_ru.txt
usbrecovery.tar.gz: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/usbrecovery.tar.gz
Alternate method files:
uImage-wdrecovery: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/Developing/uImage-wdrecovery
uRamdisk-wdrecovery: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/Developing/uRamdisk-wdrecovery
Latest second gen firmware: http://support.wdc.com/downloads.aspx?g=904

If you have not backup your My Cloud using its embedded backup feature (Backup) then one may have to find a way to copy the user files off the hard drive by removing the drive from the My Cloud enclosure and using a Linux driver for Windows or use Linux so you can access the hard drive and copy the user files from the Share folders to another location.

The problem is, if one already ran the second gen directions and ran the parted command and then ran the mkpart commands to create new partitions then its possible/likely one has erased their user data on the My Cloud.

1 Like

HAPPY NEW YEAR AND SEASON BLESSINGS.
Hey so new developments…The casing I ordered arrived a few days back but decided to get a head ache after the holidays…anyways looks am in unknown waters. So I bought a casing and found that I have very many partitions… and the ones that aren’t raw seem to be the ones that I made during the steps above.I can see the Uramdisk files… So I really dont know what to do.
@Bennor Thank you alot and am very sorry that I beg for your assistance again

What is or are “casing”? Did you buy another single bay My Cloud enclosure? If so have you checked which version it is, first gen (P/N # on the bottom of the enclosure ends with "-00) or second gen (P/N # on the bottom of the enclosure ends with "-10)? They are not the same. You cannot take a second gen hard drive and put it in a first gen enclosure and same goes for the reverse. The hardware and OS are slightly different between the two versions.

If one has obtained a first generation single bay enclosure, they can use the Fox_exe’s first gen unbrick directions (and files found in the main repository link: https://fox-exe.ru/WDMyCloud/

NO, just a generic casing to access and transfer files… as I have said they have some partitions that show no size, some that have files, size and accessible but the files in some are empty and look like they were my failed attempts at fixing because some are empty… have one of the files or both

Ah so you bought a USB to SATA adapter, or enclosure, or docking station. During the unbrick process one creates a number of partitions and then copies certain files to each of them. If the unbrick process failed the first time, try it again. Sometimes I’ve had to run the first gen directions more than once on a hard drive before it worked.

Make sure to follow the directions exactly. Making adjustments, if necessary, to the location of the mounted hard drive partitions. If creating the partitions, do not adjust their size, use the exact values in the direction.

1 Like

Yes so I believe. You are saying I do it again but this time from a machine that has Linux installed? Not used linux before so I might need some help here…like a lot. Am sorry for this

For the second generation single bay My Cloud one can use Telnet as the directions indicate. See step 4 in the directions:
4. Connect via Telnet (Search IP in your router, unde DHCP section.)

If you don’t know how to use Telnet on your computer then use your favorite internet search engine to learn about Telnet and how to start it on your computer.

If one wants to recover any of their data from a bricked single bay My Cloud hard drive then they will need to use either Linux or a Linux driver on their computer. The My Cloud hard drive’s data partition is formatted for EXT4 and is not readable in Windows without using a third party Linux driver.

As frustrating as it is these steps to unbrick an existing or new hard drive for use in the single by My Cloud enclosure are. It will require some learning on your part. This is not a difficult process as it mostly involves just copy and pasting (or typing in exactly) a series of commands. Often one may have to perform the directions more than once if they entered the information in wrong or out of order.