Unable to update firmware - Buttons grayed out

Tried the reset button in the back - same issue.

When clicking on the ‘Firmware Update’ link, the buttons are enabled for about 2 seconds then they are disabled.

You can quickly click on the ‘Update Now’ button when it is enabled and it will discover and download the latest version.

But it will hang on ‘Importing File…’

I downloaded the 1.03.41 file and tried the ‘Update from File’ but as soon as you select the file, you can see the buttons grayed out and it will never start the update.

The unit previously had version 1.02.36 and it successfully updated to 1.02.42 by clicking on ‘Update Now’ button. But after that update this problem happened. (Why didn’t it just update to 1.03.41 from the beginning?)

Is there another way to update the firmware? I read there a ‘safe mode’ screen. How do you access it?

Have you tried downloading the firmware from their site and doing the manual update? Check this page for both the link to download the file and the instructions -> http://www.wdc.com/wdproducts/updates/?family=wdfmycloud_ex4

And I don’t know where you read about this “safe mode screen” but I have never heard of or seen such a thing for EX2/EX4.

Gotcha! I undetstood your problem.
It seems that you have to create a volume first any drive will work

After that you will be able to update. Its strange but it works that way

I needed to use an oldie 500 gb drive just to update the firmware. I didnt have the reds available at that time

Yes, thanks, I was finally able to update the firmware by inserting a drive, formatting, and creating a volume. The buttons then became enabled.

WD should make a note of this to their users.

The ‘safe mode’ screen I found out from the online manual is actually just your NAS’s ip address in the browser address field. Same screen.

glad it worked :slight_smile: