Unable to see WD TV Live Hub on Network


I purchased a WD TV Live Hub last week.

At first everything worked fine. The hub was showing in the network list on my pc. I use a wired connection.

I could access all files in my shared folders on my pc when I selected Network Share as source.

Yesterday I selected “Media Server” instead of “Network Share”. I could connect to the pc and it showed my pc as [computer name]:[username]

Then I went back to Network Share. Suddenly my pc wasn’t showing in the list, but there was a message that said “no storage present”. Also the hub had dissapeared from the network list on my pc. It is still in the list of media devices though, 2 times as WDTV Live Hub and once as “LARRY-PC:Larry:”

Here is a screenshot of my current network situation.


I resetted and restarted the hub, my router and my pc multiple times with no result.

Both are in the same groupname (WORKGROUP).

I can still access the hub’s web interface on my pc when typing it’s ip address.

All internet services do work well.

Please help! Thanks!

See if this tutorial for troubleshooting helps:


Thank you.

I tried “net view” on my PC and got an error 1168.

I found that the service “Computer Browser” needed to be started. So I changed it’s setting to start automatic.

After this I rebooted my pc and ran the command “net view” again. Now it worked. The hub was showing in my network list and I could access my pc’s shared folders again from the hub.

Awesome.  Thanks for the follow-up.