Unable to recognize other network devices

I was able to access my WDTV Hub at one point, and I was even able to access my computer’s network.  Now, all of a sudden it won’t recognize any device unless it is a USB.  I have been screwing around with it for almost an hour and I’m at the point where I’m just going to take it back unless I can figure out what the heck is going on.

Any help would be greatly appreciated.

Sorry, apparently I did not clarify.

I have the WDTV Play. That’s the one that doesn’t recognize any devices (the Hub and my PC) through the network even though it did before.

ok, sorry bout that … no idea, i don’t own a WDTV Play

@ jazzyfizzle

Your message is not real clear to me, except it does appear your network may not be set up properly.  Fooling around for an hour, is just scratching the surface; especially if one is a novice at this stuff.

Suggest you contact WD Support for some assistance you are entitled to by having purchased a new unit.

What happens when you access ‘my storage’.

Have you tried a reset to factory defaults.

Can you see your network from other devices.

What devices are you trying to access on your network, is it just the hub and PC.

richUK wrote:

What devices are you trying to access on your network, is it just the hub and PC.

…and do you have DLNA servers enabled on both the Hub and PC?

I just noticed there was a firmware release a few weeks ago. Perhaps that messed things up. Is there any way to go back to the old version?

Hi there,

I have exactly the same issue. I used to watch all sorts of stuff via my MediaMonkey DLNA server (on Win7) and now all of a suddon it’s gone. When I bought the TV Play I tried WMP as a DLNA server. That worked, but now WMP doens’t work anymore either. So the problem doesn’t appear to be DLNA server related. It tried factory reset on the TV play and resetting/rebooting some things. Nothing has worked so far. The only thing I can think of that’s changed is that I’ve bought new system RAM and upgraded to 8 GB, but I don’t see how that changes anything relevant.

Would really like a solution to this, because the device has become practically useless to me now. I don’t care about all those “prominent features” such as Netflix and whatnot. All I wanted is to watch stuff from my PC in the bedroom. After being very disappointed that the TV play doens’t support folder sharing, lots of headaches to get DLNA going now I have nothing :frowning:

Hope someone can help.


I had a situation where my WMP “Play To” quit functioning to the WD player.  It turned out that I had recently installed another server program on it (i.e. the Pogoplug PC resident program) and it was overriding/blocking Play To.  I shut down Pogoplug PC, and all has been fine again.  If you did something similar by installing another server program, this could be the problem.

Nope I changed nothing other than go from 4 GB to 8 GB. Now both WMP and Mediamonkey DLNA server arent working. Both did before. I checked all settings, nothings helped.Thanks for the suggestion though.

I think the recent firmware update caused the issue. Is there any way to revert to the old one?

  I think the recent firmware update caused the issue. Is there any way to revert to the old one?

Possibly.  Find your product at WD Support, and see if there is rollback software.  Most other WD players have this available.

I just now took a look, and don’t see this as being available.  Nevertheless, go to support for your product and locate the FAQ section and see if anything there can help you.  Good luck!