Unable to map network drive on a Windows 10 machine (that used to work)

I am at a complete loss for what went wrong, but a Windows 10 box that was working well with both of my WD My Cloud Mirror servers (both now running OS5) has lost the ability to mount drives (shares) on either NAS device. The Windows machine has no problem accessing the NAS devices over the web (admin UI), and a dual-boot MacBook Pro (macOS Big Sur and Windows 10) can mount drives on both devices just fine.
The failures are always “incorrect password”, and happen for both command line and Windows GUI (File Explorer “Map Network Drive”) attempts.

For example:

net use M: \NAS8TB\MacBookFileHistory /pers:yes /user:tad
Enter the password for ‘tad’ to connect to ‘NAS8TB’:
System error 86 has occurred.
The specified network password is not correct.

The laptop connects fine, in both Windows and macOS, using the same user name and password. I created a new user (“test”) on one of the NAS devices with password “test1234” and this fails to connect as well.
It seems like something is trashed in the SMB (v3) and/or NTLMv2 password encoding, but the “broken” Windows machine can still connect to the laptop running Windows, so somehow it’s only broken when talking to the WD My Cloud Mirror devices … BOTH of them! And this was all working a week ago!
Any suggestions for how to debug this? I am wondering if I need to do a packet trace in WireShark and read SMB/NTLMv2 documentation to figure it out.
I have tried generic “fix” attempts like “sfc /scannow” and the Network Troubleshooter, but these found nothing and made no difference.
Thanks in advance for any suggestions for how to proceed!

What does your Windows Protocol section look like in OS 5?
If your firmware is 5.05.111, try enabling SMB1,SMB2,SMB3 & NTLMv1 and NTLMv2 and test the connection.


Here is what it looks like on one of my My Cloud Mirror gen2 devices (the other is the same):


Changing the section to match what you have changes the error message from “bad password” to “Access denied”:


This is what the section looks like after changing it:


Thanks for the suggestion … though I think that SMB1 is forbidden in this version of Windows unless you force it on in the registry.

This is the version of Windows I am running right now:


Let me know what else I can try … thanks for your help!


SMB v1 is disabled on this machine. I may have done this myself after reading an article encouraging me to do it …

I can try to re-enable it if you think that would be worthwhile.

This is the error that I got before changing the parameters you suggested (this is the other NAS):


Hey, making progress!

I poked around on the web UI and discovered that I had accidentally changed something in my debugging attempts yesterday. I had tried setting the File History share to Public access to see if that helped, but it didn’t help so I changed it back to Private.

BUT … this cycle cleared all of the accesses for individual users that I had set up, with the result that my “tad” user had been set to “no access”. This is the reason that, after making the changes you had suggested, the error message changed to “Access is denied”.

Re-enabling my user access to the share now lets me connect (I tested using the Windows File Explorer GUI) and File History works again.

Cool, major progress!

So, I guess the next step is to try various combinations of lower SMB and NTLM versions and see what works and what doesn’t. My original setting of SMB3-only and NTLMv2-only is what I would have wanted, but if it doesn’t work then knowing what DOES work should be valuable.

It seems to be NTLMv2 that isn’t working. I restored my original settings, except for allowing both NTLMv1 and NTLMv2, and this works. The pop-up setting help indicates that NTLMv2-only is the default setting for OS 5, so this does not appear to be self-inflicted.


I’ll read up on NTLM versions and see what I can learn.

Note that my laptop running the same version of Windows works fine connecting to an NTLMv2-only NAS, so there is something funky on my desktop machine that is not happening on my laptop.

Similar assumption here. I am running the latest windows (Version 10.0.19042.630) on my laptop and the latest firmware for My Cloud OS 5 (5.06.115). When i try to map (net use <drive>: \\<my-ip>\<my-share>) a NAS share i get the message “invalid password” as long as NTLMv1 is disabled (which is the default). Enabling it back again the share can be mapped. Note: SMB1 is not active on the NAS.