Windows 10 and Cloud OS 5

Hi Forum
Last Night, I upgradet my Cloud Mirror device to Cloud OS5, without any problems. I use the device to back up my large library of Photos and 2 Windows 10 Pro Cpmputers. Both Windows Machines are Version 2004 (OS Build 19041.450). Additionally, i connect a MBP late 2017 (latest Mac os Catalina)to the Photo Share, not out of necessity, more for test reasons.The one Windows 10 Laptop connects fast and without any hesitation to the shares. The same does the Mac.I can freely roam the folders disconnect and re-connect.

But not the main computer, a Windows 10 PC which connects hardwired. The machine sees, refreshes and lists the shared device/folder but does not let me connect to them. I added the device with hostname, user and password to Windows Credentials, which makes the difference that a login window appears, letting me enter the same user and password I successfully entered on the other 2 devices, but to no avail: “Wrong user or password”. I tried to connect with the hostname AND the IP, the machine pings the device without any problem. But no connection.

I did reset the system settings, and even restored an older settings-backup of this device. No Joy. I checked all relevant services, none were off, i played with all SMB settings - but what worked only yesterday morning, hell what worked flawlessly the last years, does no longer work today. I should never have pushed that upgrade button!
I tried to check and copy all the settings and working services on the laptop, equally to no avail. Same subnet, same Workgroup, same DNS. It just won’t let me in, which is driving me crazy. Is there no way of restoring the old OS? Does anyone of you have an idea what i might have overseen?


Not sure I can help. . .

. . .but certainly Windows Credentials manager caused me some grief with setting up the NAS unit.

It seems that fundamentally, the credential manager only likes to have a SINGLE user/PW combo for each device/IP address that is being accessed.

What this means is that you cannot have two Users on a NAS use a single Win10 account.
When I was testing multiple NAS users; I basically had to use on PC for each user.

When I was done playing; I “reset” credential manager by deleting all references to the IP address and the NAS. Once this was done; I was able to log in using my chosen “account” on the NAS.

I don’t think wired/vs wireless makes a difference in this case.
I don’t think an “older settings/backup” will work well if the older settings was for OS3 config.

While the device should work if you use automatic DHCP; I have a fixed IP assigned from the router. Not sure that will help you.

1 Like

Thank you very much for your answer, I will certainly try to follow all your points once I am back on my desk at home. I am a Photographer and not IT Expert, so I need to be elsewere some of the time. Right now, I am trying to migrate som of my crucial data to a Synology NAS Server in order to be able to do the most of my work. Stuff that can’t wait. My editing software is accessing the Catalogs on the NAS, right now paralying me in doing my work. You might ask why I don’t keep the work on the desktop, I have my reasons…
The Synology is working very well, and i am thinking of making the switch forever. Ironically, the WD seems to work better than ever on the other two computers. I just don’t have the time trying to make it work on this machine, when everything else seems to work like a charm.
Now your tips:
Working the Windows Credentials:
I have been there too. I have tried to work without anything WD related, with the WD’s hostname and with the IP, and both. The only difference was that it either let’s med enter my password (and from the very beginning informing me that it is either the “wrong user or the wrong password” - or it tells me that “the network path could not be found”. Even if the NAS show instantly in Windows Explorer.

Even if it is not best practice, the username I use is the only one, besides the admin. The one I always used to access my work. As much as I can tell, it os not possible to disable the admin account or security reasons, as Synology stresses it’s users to do. So: only one user here on WD. Besides: The 2 other machines (Win10 and MacOS) do not seem to have a problem with the old user setup, two users, logging directly into the account in question.

I always had the IP set from within the NAS. Static. However, I tried to assign static IP on the WD, as it was “before”, and i have tried to go DHCP, assigning the IP from the router. Doesn’t make any difference.

I used the old Settings as a test. It didn’t make any difference, and I restored the OS5 ones…

No, you are right, wired vs. wifi doesn’t make any difference. It wrote it because the two machines actually connecting to the WD are both doing it wireless… With unseen speeds.

This is indeed causing med a lot of grief and stress, and I am stunned that one single upgrade can entirely paralyze my doings, going from “doing well” to “completely useless” within 15 minutes.

Later today, I will try to erase the one of two user accounts on the WD, trying to access the disk with only the admin, if that is what you suggested. I does not make much sense to me, but if it makes af difference…

In the end, I will have to migrate my 2 TB Libraries to the Synology, having to trash a perfectly well working WD.

my experience is that you can have ONE account on a Win machine per device/IP address. It could be the user account, OR the admin account.

If you have no accounts that have been connected from the PC. . . the first time you try to access it will request credentials. Once you enter one set of credentials. . . it will reject the other set of credentials. (unless you do something in the credential manager)

Yes. … the OS/5 seems better behaved on my system that OS/3 as well. . . .as I use it. The web apps (and the associated indexing) is where the problems start.

Edit: Also, check this: Network credentials are incorrect from my Windows 10 and i can't map again my shared units of my PR4100

Sorry, I do not understand your Edit at the end of your comment. Could you please elaborate?

I have two users on the WD: the admin and the one I always used for almost everything, in particular the access to my libraries. This has never been a problem. The Credentials Manager contains this user only. I do not have problems to access the ui from the browser.

This is beginning to get very weird, as this should definitely not be rocket science.
Is there anybody able to share what settings they use on the WD NAS, like SMB, like everything else in the tab “Network”. Of course without any critical info?
I have a Windows machine connecting without problems. I think I copied pretty much every setting from this machine. Maybe i missed soemthing like in Services.msc end gpedit??

That’s ok. . .I don’t understand it either except that LmCompatibilityLevel may be incorrectly set. Which is why I directed you to threads that go into more detail.

I can check LAN settings on my system probably tomorrow (I am out of position at the moment)

Thank you, NAS_user
I thought about reinstalling Windows (the obvious, since the NAS can be accessed with everything else but this computer) but I just cannot do that, as this would cost me several days of work (reinstalling all specialized tools and applications, reinitializing everything needed to do my work? It would be disastrous.
So I tried to “System only” restore the WDMCM. Once it came back to life, it was presented with all the initial OS5 stuff, releasing me into the known UI. All shares still were there, put on “Public”. I chose not to re-establish the second user, since I renamed the admin user to something else, keeping it the sole user on that system, with r/rw rights on everything.
Now, as long as i kept the most important shared folder “public”, a successful connection to the NAS was made, listing my catalogs and libraries.
Disabling the Public privilege makes Windows asking me user credentials right away, of course it does… I enter those (newly created and carefully noted-) credentials and get rejected as fast as I press Enter.

Credentials Manager empty - check
Router assigned IP/DNS - check
Windows Network resetted - check
netsh winsock reset - check

What am I missing here???

I have wasted another morning on this issue and I do not have anymore will and time to continue as I am very tempted to make the change from WD to this Synology I borrowed from the local nerd. I have ordered a 6 bay Synology Server DiskStation and will make use of this device from now on. The WD here get’s the hammer afterwards. I consider this thread as not solved bud closed.
Thank you for your time and help.
Cheers from Denmark

This is probably the same issue that I hit (unsolved so far), filed today as
" [Unable to map network drive on a Windows 10 machine (that used to work)]"
(Unable to map network drive on a Windows 10 machine (that used to work))
For me, though, it seemed like things were still working after both a Windows 10 update (to 20H2) and the My Cloud Mirror update to OS5 (now with firmware 5.05.111). I just updated my laptop to Windows 10 20H2 and it is still working, but perhaps by tomorrow it will also be broken. Perhaps an engineer at WD has some ideas …

I had the same issue until I (re-) activated NTLMv1 (and not only NTLMv2) under NT-LAN Manager (Windows Services). This option was deactived through the OS5 upgrade.