Unable to login to WD MyCloud Sync

Been trying to setup WD Sync on my MacBook to my WDMyCloud 2Tb. When going through the setup it asks me to enter in my password for account steve, I type that in but says invalid password. I can connect to the network shares using the same details and to the web GUI. Have reset the password to something else and still the same.

Any suggestions would be great


Normally the password you use for the shares and the drive is a different one for the mycloud.com account. Try to see if you are putting the email and your mycloud.com user qand password to check, if it does not work go to mycloud.com tot he forgot password section. Hope this helps.


Thanks for the reply. It asked me login to mycloud account so I log in, then I press mycloud device so that it gets a screen tick, I press next and then another box appears. with my user in there, I type in my password same as for the network share then it says invalid password. I can login fine at mycloud.com and access file etc

The MyCloud.com credentials have nothing to do with local WD Sync, surely?

In a way the MyCloud.com web portal login does have something to do with the “local” WD Sync program. There is an option (see screen capture below) where one can sign into the MyCloud.com web portal to setup the WD Sync program to access and sync offsite to My Cloud’s. Normally one who is syncing across their local network wouldn’t go the MyCloud.com login route but the option is there none the less.


I have tried signing in and then doing it without signing in and just using the details I use to access the local share. either dont work

see my screen shots

Okay. But I did say local WD Sync…

The OP didn’t mention remote access, so I was really questioning why mycloud.com was mentioned…

you have resolved this problem?



Resolved this by doing a restore on the box

Thank you very mouch

best regard


@Steve_Tozer when you say you resolved by doing a restore on the box. what do you mean?
what did you restore? i’m assuming you mean restor on the MyCloud itself?

My issue is that I can’t get the WD access to go through the setup process. i’m coming back to this issue after waiting for a few software upgrades to WD sync. and now can’t get my pwd to take on the screens you reference. so the process just fails (no error) just disappears and there are no options in the WD Sync menu as accessed from the system tray.

win 10, new machine. (note i did get sync to work on a win 7 machine so know what success looks like. curious about your resolution to the PWD issue.


One can do a 4 second system reset or a 40 second system restore via the reset button on the back of the My Cloud. A reset will reset the administrator password to blank/no password. A restore will reset/clear both the administrator name and the administrator password. More information can be found at the following WD Support document:


Those who are looking for a solution for “Invalid Password” on Mac Book and iMac. here is the solution.

  1. Uninstall WD Sync
  2. Reinstall WD Sync
  3. Connect your Mac with a different Network(Not the network your WD Cloud is connected)
  4. Sign in to view all your MYcloud.com devices (Sign in and you will instantly see your drive associated with your account)
  5. Click on your device and it will instantly bypass user-Sign and your WD Sync will start working with User automatically logged in.