Unable to login to cloud sync on Mac

Hello,

I have recently purchased wd my cloud 2TB drive. It is all setup and I am able to sync up my folders from windows machine but when I am setting up the WD sync on my MacBook it is not letting me login. I am able to install the WD software but when I launch the WD sync application, it asks for me to sign in at the bottom of the window with the email address and password which I a able to sign in. It then has the WD icon in the middle for my WD cloud drive with the correct name so it is able to search the drive on my network. The “Next” button is greyed out until I click on the icon. As soon as I click next a small pop-up window appears which has the three users on my WD cloud drive (including admin). I tried to login with all three but it keeps throwing error message that the password is incorrect even though I can use that admin username to login through the web browser. Interestingly, when I set this up on windows machine, it never asked me for the admin password (only the email sign in at the bottom of the screen). I would really appreciate if anyone can help.

Thanks.

Are you accessing locally, or remotely?
What software did you install on the Mac?
Did you create the Users that you are being presented with?
If you are accessing locally, you should be using your mycloud user name, not the email address. It sounds like your Mac is connecting via the internet, not via your local network. How is you Mac connected to your local network?

Make sure to follow these instructions:

Configuring WD Sync with a My Cloud

Or contact support directly for further assistance:

I am accessing it locally.
WD Sync Installer is what I installed.
I have the admin account setup and two more uses setup. I have tried the password for all three users.
MacBook is connected with the same wifi as the WD cloud (local).

I have the same problem.
After the WdSync install, I sign in to MyCloud (with email) and then chose the unit and write the right password for the user (the local one).
But it reply that it’s wrong!
A workaround is a soft reset of the unit but I don’t want to recreate all my shared folder!
I hope for an update…

well, I reset the unit but wd sync still doesn’t work.
I am trying to access locally but when I choose the local user (the MyCloud user is signed in) I received always the same message “wrong password”.
I have also tried to cancel the password for my wife (in user profile) but nothing…
any solution?
thanks

Which password are you using for local access? The My Cloud Dashboard User password or the MyCloud.com web portal password? For local access you use the User password created in through the My Cloud Dashboard.

I try to access locally so I am using the local one (user with name).
however in the wdsync splash screen, I am also logged to MyCloud.com (user with email).

I don’t understand. Are you saying you use two sets of login/passwords in the WD Sync program?

Normally one would use just/only the local WD Dashboard created User name and password NOT the MyCloud.com created User and password.

The WD Sync program does offer the option to use the MyCloud.com created User and password but typically one has to select that option. Below is an example of when you would use the MyCloud.com created User/password.

I have tried to sign in to MyCloud.local with the local user (name/password) with and without signing in before to MyCloud.com with the wd account (email/password) but WD Sync doesn’t recognize my local password…

thanks for your support
:wink:

Was anyone able to solve this issue? Problems when setting up “WD SYNC SETUP” on MacOS X High Sierra.
Issue is exactly like described above, app does login to mycloud.com however not possible to login with new non-admin user to the device itself via APP on the next step. Login works over the local network, however app says “Invalid password” on the login screen where user is selected via dropdown.
Device: WD MyCloud EX2
Firmware: 2.11.169
WD App Manager (WD Sync) version: 2.0.1.72

Screenshots are listed below:

I have tried all possible combinations: adding new user via mycloud.com, deleting, adding user via local cloud dashboard, resetting password but no success. I can login with anything, just not WD Sync.

I’m facing the same problem with a fresh install of WD Sync.
The password I used is correct.
It still says the pw is not correct. The same password and userid works when I login via the webpage.

It worked on my iMac and MBP but it does not work on another mac that I have…

Me too. I have a ticket in with WD support so lets see what they say. Frustrating

1 Like

Same here… any1 solution? (MacBook Pro Mojave)

Hello mvanimpe, please describe exactly what steps you have taken and in what order.
I had the same problem but I solved it. Before I describe what I did it would be helpful to know what steps you have undertaken. it is possiblöe that the order is incorrect.

This is what the support made me do (didn’t help)

I would advice to perform some steps to re configure your devices’ network setting:

-How is the device connected to power and router?

-What is the led activity of the device and the Ethernet cable?

-You are trying to access the device from web browser? Mobile app? File Explorer or Finder?

-What happens in these cases?

Maarten Van Impe

0472907365

Maarten, Lets go back to step one

  1. use the WD Sync de-installation program,
    2.then move the de-installation programm to the trash. (I use AppCleaner) check that all remenants have been removed.
  2. go to the library that you see when you open you hard disk
  3. Navigate to application supp and put the folder WD Sync into the trash.
  4. leave the this library and go to the library at Your user level
  5. in the folder Application Support remove the WD Sync folder
  6. In the folder Application Scripts remove the two folders that start with com.wdc…
  7. now go to the caches folder and remove the following three folders to the trash:
    a.) com.wdc.branded.WD-App-Manager
    b.) com.wdc.WD-Sync-Service
    c.) com.westerndigital.WDSyncInstaller
  8. now go to your Preferences folder and remove the two plist that start with com.wdc…
  9. Almost finished. Now go to your document folder and remove the folder DeviceCache.
  10. Now restart you device after 5 minutes and wait til its completely powered up
  11. then reinstall WD Sync.

It should work now.

No luck :s

Maarten Van Impe

0472907365

Same issue here. After installing an new Mac by TimeMachine backup, sync does not work. I deleted the sync app. (conform instructions from WD help). But when installing Sync again i can not log in during setup.

The password is correct. I still can log in as Admin in dashboard.

Problem still exists in my case