Can't sign in using WD Sync

Bought a MyCloud box last week and am uploading to it successfully. But just installed WD Sync and I can’t login to that. I type in email address and password (as used to access MyCloud remotely) but nothing happens. The login screen just clears and reappears.

Hi, what operating system you have in your computer? What version of the firmware is running on your system?

Windows 7. I don’t know what version.

After trying ten times (the same email and password) it started. But it is so SLOW! And I can’t tell whether it’s doing anything at all.Is there some progress status?

Hello,

This sounds like a network timing issue.

Check your My Cloud device to determine if it’s in Relay or Port Forward mode.
Relay mode may be slower because your communications are being replayed (proxy).
If in Port Forward mode already, them something else could be the root cause.

Please check your DNS from the remote location and ensure that mycloud.com wd2go.com and wd.com are all resolvable using the nslookup command on your PC.

IE: Open a DOS prompt and type

nslookup myloud.com
nslookup wd2go.com
nslookup wd.com

You should also check ping reply times

ping mycloud.com
ping wd2go.com
ping wd.com

Lastly, check network connection times from your location to the external IP of your router.

I seem to be having the same trouble.

I have a 3Tb MyCloud setup at home and syncing on the local network there.

I went to work today and installed WD Sync on my laptop. Install seems to go ok. Setup I acknowledge the ELA and it begins looking for devices. It doesn’t find any because I’m not on that network. So, I try to login to MyCloud.com. I enter my email and password and the screen flashes clears the fields and reprompts me for email and password. The logon and password work because I can login at mycloud.com.

I have uninstalled and reinstalled WD Sync Several times–same result.

I have tried to do this on two different networks (not the home network).

I am using the current version (updated) of Windows 10 on a Lenovo laptop.

nslookup and ping work for mycloud.com and wd.com. They fail to connect with wd2go.com.

Any suggestions?

I went back to try this again. Now, after the username and password are entered and I hit the “Sign in” button, I get a pop-up box that says, "WD Sync X The remote name could not be resolved: ‘api.wd2go.com

I have no idea what to do next.

Basically if api.wdc.com and www.wd2go.com cannot resolve, WD Sync will not function correctly.
This KBA has the troubleshooting steps IF the login would actually work and WD Sync didn’t see a My Cloud.

OK, thanks for the reply. But where you say, " if api.wdc.com and www.wd2go.com cannot resolve, WD Sync will not function correctly," how do I fix that?

BTW, I am trying to install WD Sync on a laptop connected to a different network than the MyCloud that I am using–am I barking up the wrong tree with this approach?

Thank you.

Hi. I’m jumping on this thread because it describes the exact same problem that I am having, and it doesn’t seem to have been resolved for the previous user, so hopefully this can get resolved and we’ll all see the answers.

So just confirming the symptoms: I have installed WD Sync. I get to the screen where it says “Sign in to view all of your MyCloud.com devices”. I click “Sign in” and the email address and password box appears.

I enter my credentials and the box just immediately refreshes - wiping the credentials I entered and ready for me to try again. No error message is given. I can use the exact same credentials to successfully login to mycloud.com in a browser.

From the above advice given by WDStaff I tested using nslookup for the various addresses listed.

These nslookups are successful:

And these nslookups failed:

  • wd2go.com (So the www. subdomain works, but the root domain doesn’t).
  • api.wdc.com - non-existent domain. Perhaps this was just a mis-type in the advice above?

I tested these same domains using the DNSLookup tool at mxtoolbox.com and they gave the exact same results.

So my computer’s DNS matches mxtoolbox.com results, which suggest that my DNS is not the problem.

And I still have the issue of the login box just refreshing each time I submit my credentials.

What can be done to get it working please?

I had exactly the same problem. Tried two different desktops (different networks) two different laptops (also different networks). Failed to log on just as described.

I even tried to setup a new mycloud.com account.

Never got it working, resolved I would not be using it.

An update - I tried logging in again, and it worked. Didn’t do anything differently, so wondering if their API happened to be down for a few minutes when I first tried? So not sure why, but I’m now logged in.

Josh and Everyone else with this problem.

I think I have a solution

I was moving my WD Sync from a Windows 7 to a Windows 10 machine. During installation I was unable to login with my mycloud.com credentials. Like above, during the initial installation, I was putting in the username and password, and the box would flash and delete my text. This would continue ad nauseam.

The fix:

  1. I just closed the “login box” by clicking the “x” in the corner, and finished the installer.
  2. I made sure that my network connection was set to Private.
  3. The program is now installed but not configured.
  4. I opened the windows menu and searched for “wd sync” and opened it. I saw it populate in my task tray.
  5. I right clicked the icon and clicked “settings”.
  6. I clicked on “add” and the login box reappeared. This time my credentials took, and I was able to login.

I hope this helps some others. I became a member just so I could post this solution.

Good Luck.
JD

3 Likes

JD…you are THE MAN!! I was about to throw my laptop in the pool. I’ve been trying to get this to work on a new laptop for at least 30mins. Your post was spot on!! THANK YOU!!!

THANK YOU JD!!! You are THE MAN!

I’m so glad this helped you! It was worth my time posting.

I did all those steps in my PC and didn’t help, but then I tried in my laptop, and it worked.

When I did it in my laptop, I reached the following steps:

  1. I opened the windows menu and searched for “wd sync” and opened it. I saw it populate in my task tray.
  2. I right clicked the icon and clicked “settings”.
    Sem%20t%C3%ADtulo
    “Configurações” being “Settings”

But when doing the same steps above in my PC, I don’t get those options:
Sem%20t%C3%ADtulo2
Only “Help”, and “Exit”

Does anyone know why that happens? Tried all the above from previous commenters.

PS: Both systems are Windows 10