Unable to access Web interface Dashboard post upgrade to My Cloud OS 5 Firmware 5.06.115 (My Cloud EX2 Ultra)

I’m Unable to access Web interface Dashboard post upgrade to My Cloud OS 5 Firmware 5.06.115 (My Cloud EX2 Ultra)

When I enter the IP address into the web browser, I see the message “You don’t have Authorisation to view this page” HTTP error 403.

Kindly note that, im able to access network folders of My Cloud EX2 Ultra, but unable to access only the dashboard login page/web interface.

How do i access dashboard now? Can someone help me in this regard. Please do provide me the fix for this issue.

Kindly someone revert back to this issue, if fix is found.

I solved the problem by changing the ip address device. Change your ip to 172.16.x.x or 192.168.x.x

For anyone else who reads this, I have an EX4 and the problem is the same. I separate devices using sub netting. I am not changing my network arrangements because I separate all the device for security purposes as I don’t want generic IoT devices being able to access/hack PC’s on the network. OS3 worked perfectly but OS5 broke this arrangement. If you use sub netting, DONOT upgrade. I have logged a formal support request with Western Digital and am awaiting a response to the issue

  • Firmware 5.04.113 and 5.05.111 restricted access to the dashboard to local network and same subnet.
  • Firmware 5.06.115 allows access to the dashboard from different subnets but not over the internet.

If you cannot access the dashboard in 5.06.115, chances are you have more than different subnets between your computer and the My Cloud OS 5 device as the adminUI will block and deny any and all access if the source is coming from a Public IP address.

If would be interesting to know more about your network configurations.

It seems the dashboard access only works for ip ranges 192.168.x.x and 172.16.x.x. Many hours wasted figuring this out and changing settings across my network.

I would not define that as a solution actually. You can do that for simple network setups, but when you have lots of devices connected with static ip rules it becomes extremely time and costs consuming to reset the whole world for just an issue on a single device. Maybe you can do that in home arrangments, but for small\medium offices it is definetly worth changing the nas for another one of different supplier and, for sure, not considering WD products in future hardware refills\upgrades.
I really can’t understand the reason for this, let’s call it, “upgrade” .

As it is home use and therefore to the best of my knowledge on the same net I do not understand how I am still getting this problem.

Still unable to access on my TV even though changed smb settings as well

@SBrown Hi S Brown, configured ip range. Changed to same subnet. You’re right, it was different subnet over internet. By changing its subnet range, its working now. Issue has been resolved. Thank you for providing information in this regard. :blush:

@Dpetrikov Hi there, Yes you’re right. As you advised, i have changed the ip range and now its working good. Thank you, Issue has been resolved. :blush:

That’s simple programmer’s laziness. The simply hardcoded private ip ranges in.


but I call this nonsense.
The way I set my office network is not WD business whatsoever.

Well, someone needs to SSH into the box and patch the Apache settings.

hi Brown, i try to access ftp via internet but fail.
if this policy apply for ftp or not?

@chenxiong the access policy only affects the AdminUI, dashboard and not FTP Server.
Check your FTP Client Software to see if it is using SSLv1.0 which is not supported in OS 5.

1 Like

if I just know how to do that…