Unable to access as network drive


   I have recently updated to Windows 10 Pro Technical Preview build 9926. I hadn’t tried to access my WD live for a while, but I have a feeling it’s due to this update.  I am able to access the dashboard, the Twonky Media server, as well as access everything via the WD Cloud app. I can ping the drive. I have admin rights on my PC. When I try and access \MYBOOKLIVE from file explorer, I get an error that states “The account is not authorized to log in from this station”.

Typing “net view \MYBOOKLIVE” in command prompt yields “System error 5 has occurred. Access is denied”. It shows up in the same workgroup.

Any ideas??

I just checked, I can access it via wd2go.com as well.

same problem here.  was fine until the more recnt win 10 update

I have the same problem. There’s a notification that there’s a firmware update. I am hoping that will solve the problem. However, no one has replied to your queries, guys!  How do we know t will solve the problem? The firmware update requires that we back up files first before updating but since I cannot access my files through the network, how do I back up my files? The last time I backed it up was October last year. As you can,I can access them through my andorid and internet but I cannot copy the files from there (or can you?). I can’t even save files from my laptop to the unit. So frustrating!


Updated MBL firmware. Ran windows update again for a few new items.

Still nothing.

Paroused the Technical Preview forums and found this:


Use RegEdit

create a Dword called ‘AllowInsecureGuestAuth’ in HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters and set the new value to 1

Then close Regedit



Worked like a charm.

Thanks, that worked for me.