Windows 10 can't access files on MyBookLive but can configure the drive

Hi: I started a new thread on this issue because my issue is different and the other thread is confusing.

I updated to Windows 10 Pro yesterday. Everything but access to the files on my MyBookLive is working ok.

Some facts:
I can still access the drive in every way from other PCs running Windows 7
On Windows 10, the drive shows up in “Network” in three places:

  1. Under Computer as MyBookLive
  2. Under Media Devices as MyBookLive-Twonky,
  3. Under Storage as MyBookLive

Attempting to access MyBookLive under Computer, reports “One or more protocols are missing, Windows Sockets registry entries required for network connectivity are missing.”

Attempting to access MyBookLive- Twonky works exactly like it should.

Attempting to access MyBookLive under Storage accesses the Web Configuration Panel for the MyBookLive unit, but I cannot access my files from there. However I can configure the drive in every way.

The above proves that the drive is installed and that Windows 10 can find it and talk to it. However, it cannot access the folders installed on the drive like Windows 7 could.

I have tried the many solutions discussed in other threads, but these seem to be aimed at problems accessing the internet or seeing the drive. They do not specifically address the problem of seeing the files themselves on the WD MyBookLive.

Things I have tried include editing the registry to change permissions, using Netsh, setting up a new shared access account on the drive withe same name and password as my PC, accessing the drive via its IP address, etc

BTW, I also got a call from a friend who inadvertently let Windows 10 install on his computer. He now has exactly the same problem on an older MyBookLive. Mine is relatively new.

Also, I have no problems accessing a USB drive installed on my Router or two very old Maxtor NAS units installed on my network. Only the WD MyBookLive has this problem. It worked just fine before Windows 10 and it still works just fine with all the other Windows 7 computers on my home network.

This is a ridiculous problem to have. There must be hundreds of thousands of very frustrated WD customers out there. Surely this should be as simple as updating the firmware on the drive or installing some new (or existing) drivers in Windows 10.

Can anyone help?

See if you can access it via Windows explorer, type:
\\the-ip-for-your-MBL

or:
\\your=-mbl-name

If you can, just use that IP to map shares.

And yes, lots of frustrated users and no, no WD fault. It is a Windows 10 issue. I also believe it was fixed on their last update. Internet searches will give you plenty of result for it with just about any NAS brand.
https://www.google.com/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=windows%2010%20nas%20drive

I should have mentioned that it is also accessible via its IP address. But that will only access the main configuration web portal. I cannot access the files that way.

I have tried to use the IP to setup mapping access to the shares. But I am still totally new to Windows 10, and can’t figure out how to do that correctly. So I don’t even know if it works.

Thanks for the input and thanks for the longer term hope that MS will fix it for us.

I can wait for that, but right now, I just need to access my files.

Cheers & thanks!

read my post again, try it by IP using “windows explorer” (this is via SMB), not Internet Explorer (http)… you should be able to see the files. And map it the same way, using the IP as specified earlier. If do not know how to map it by IP, google is your friend. :grinning:

Also see:

Added:
You do not need any of the WD tools/apps to have a fully functional MBL. If you learn how to depend on the build-in tools in Windows, you will be set for life regardless of any NAS brand you might have.

Doesn’t work from Windows Explorer or Internet Explorer. In my earlier reply I was referring to Windows Explorer. For some reason, entering the IP address in both windows or internet explorer does the same thing - it accesses the drives built in web portal for configuring the drive.

I tried googling mapping as you suggest. It confirmed that my earlier attempts were actually correct. It just doesn’t work. I get the same error as I get trying to access the drive from the Computer Section of Network - ie One or more protocols are missing…

BTW, How do I check my windows build? Edit - Just googled it. My build is 1511 OS Build 10586.164. I assume it will update on its own shortly.

That makes no sense, Windows explorer will not show you the dashboard, assuming you are typing it correctly “\\the-mbl-ip”. Totally different protocols. Attach a pic.

What are you typing to access it and see the dashboard (aka web portal)?

Actually in win10 is not called Windows Explorer anymore, it is “File explorer”.

You are right. I was not using File Explorer after all. In fact, I’ve probably never used it before, not even in Windows 7. I always used “My Computer” thinking that was an easier way to access the file Explorer.

I guess that My Computer is some kind of hybrid browser/file manager. It certainly looks like a file manager once you dig into the directory. Apparently it’s not.

As you expected, when I use File Explorer directly from the start button, I don’t get the dashboard. Instead, it goes right to the error - “One or more protocols are missing…”

Thanks for digging in and setting me straight on the file explorer.

But still lost without my files.

Looks like I won’t be getting the updated fixes for Windows 10 anytime soon.

Apparently, you have to be a “Windows Insider” to get these updates.

They should provide updates to do stuff like this sooner. I really don’t like waiting forever to get an update that addresses a problem that should not have happened in the first place.

Any idea when this fix will get rolled out to the general public?

Had a very frustrating time trying to access MyBookLive after upgrading to Windows 10. Tried all the different suggestions on the various threads in this forum. Then I looked at the MybBookLive firmware version installed and noticed it was still using a 2012 version, which was installed when I first bought the product. Updated my firmware to the latest version and it’s working like a champ now with my Windows 10 machine.

Posting this on the forum to remind people not to forget to try the obvious.

It’s a good reminder to check updates.

Unfortunately, mine is up-to-date (just checked it again) and my NAS is still not readable from my Windows 10 pc. I still need to use older computers to get at this drive.

Hard to believe this known problem hasn’t been fixed yet…

Cheers!