Windows 10 Cannot access My Book Live with File Browser

My PC does not recognize mybook live drive.
I have some pictures of the problem I get

So it shows an error

My Book Live is not present into the network files

But I can access it using the IP address of my Book Live

Please help me to sort out this problem



Sounds like the unit is not connecting properly. Have you tried resetting the unit? If not, please try that.

See page (125) of the user manual for detailed information on how to reset the unit.

Hi ERmorel,

I didn’t reset the unit as i have stuff inside. I would like to send some pics to show the problem but here I cannot do so…I do not think that resetting the unit will solve the problem…

Having the exact same problem, and like the OP I can’t reset because I have 2TB worth of files stored on it that I don’t want to lose.

Help please?

1 Like

Found a solution on another thread.

Open ‘File Explorer’ (not internet explorer and not my computer) and in the ‘address bar’ type \mybooklivename\ Where I have typed mybooklivename you type the actual name of your drive as listed in the system page you get from the ip. This should bring up the contents.

The solution I shared above worked perfectly yesterday. Today I am just getting a message saying Windows cannot access the drive.

I will NEVER buy a WD network drive again. Have had nothing but issues, and because they don’t have a USB port as a back up method of accessing files, you are completely stuck.