My Book Live not showing up in Networks on Windows 10 anymore

Hi everyone. Have looked around everywhere trying to get an answer to this and can’t find it anywhere!

I’m running Windows 10 and have been using my My Book Live with no issues at all. It seems as though something has changed (maybe a Windows 10 update?) and now my view in File Explorer is totally different.

I’ve attached a screenshot. I used to have a “computer” icon which I could double click and explore my files. Now I have a mobile phone icon and double clicking opens the Admin page in web browser. Double clicking the storage icon just open properties. There is no option to “open” by right clicking as described in another thread on here.

The My Book is definitely connected as I log into the Admin page with no issues.

Can anyone please help me get the My Book back in my “networks” so I can browse to my files again?

Thanks in advance for your help

Have somehow managed to solve this!

You need to download WD Discovery tool (just google it) and it will find the server as storage. You then select it and click Map Network Shares. I then clicked no to do it manually. Select the share you would like and it will let you choose a letter to assign it to (your personal choice). It will then prompt you for username and password. Leave “nobody” in username and enter your MyBook password (make sure you have no windows for your Share open) and it will then map the drive and appear on your File Explorer as the letter you chose

1 Like

Hi,

Thanks for coming back and share the solution with the community. Hope this helps other users asking the same or similar questions.

I’m glad you were able to resolve your issue. I did want to point out here that we have not tested or certified WD Discovery as compatible with Windows 10 - based on your experience it looks like its working for you, I just wanted to caution people who may find this in the future.

For help mapping a drive letter, we do provide the following KB:

Windows:

Mac:

I hear what Great_Scott says. Having said that, I use Windows 10 and have a MyBookLive Duo NAS. When I changed to W10, Quick View stopped working and I could only access the NAS via the file explorer option. Then after a couple of weeks, with no action on my part, Quick View started working again, even though it’s apparently not compatible with W10!!!

The problem is that Windows 10 and MyBook Live Duo do not connect in the same way. To make Windows 10 connect to a MyBook Live Duo you need to do the following. This will mean that all computers on the network can access every file on the MyBookLive and the Windows 10 computer will connect to computers on the network which are not password protected - just like Windows XP and Windows 7 did. This is not ideal but it works.

Log into the MyBook Live Duo Console
Go to “Shares”
On each share, Under “Share Access”, select “Public”
This means all network users can access the whole MyBook Live Duo but sadly this is the only way until WD write new Windows 10 compatible software. I believe they have no intention of doing this despite the fact that MyBook Live Duo is still available for sale at retail outlets. At least this way the MyBook Live Duo is still usable for something.

On each windows 10 Computer you want to use to access the MyBook Live Duo over the network.

Control Panel> Network and Internet> Network and Sharing Centre>
Click “Change advanced sharing settings” (At top left of screen)

In “Private (Current profile)”:

Tick “Use user accounts and passwords to connect to other computers”
(If you use Homegroups then maybe this will not work)

Expand “All Networks”
Tick “Turn off password-protected sharing”

Apply changes and Restart computer.

Then in the start menu: Under “All apps” click on “Windows System”. Then right click on “Command Prompt” > More> Run as Administrator.

In the command prompt:
Type:
sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
Press Enter. It should say Success
Then type:
sc.exe config mrxsmb20 start= disabled
Press Enter. It should say Success

Restart the computer.

You will now have full access to the MyBook Live Duo.

Sadly this technique allows your windows computer to connect to other non-password protected computers. This is something Windows 10 was designed not to do normally. If you just have a home network then this may be a reasonable compromise in order to keep using you MyBook device.

Hello there. Got a new laptop loaded with Windows 10 and can’t see MyBookLive on my computer as I used to see it with my previous laptop on W7. I installed WD Discovery but it did not help either since Discovery does not even find MBL. From a desktop under WIndows 10 I have no problem to see MBL. It only show the UI interface when trying to open MBL icon under the Storage folder. I read the threads i community for similar problems but could not find any working solution until now.

Help very welcome.

Just in case someone new sees this, I just got on-board with Windows 10. My previously mapped MybookLive folders would show under Windows Explorer’s Network Storage but not mapped. Also the contents of folders were not showing and I could not map them.

I found the solution: I had answered the new Windows 10 installation with my Microsoft Account. This caused my Windows 10 login to be the Microsoft account instead of a local account that matches the Mybooklive user account I setup in the Mybooklive dashboard when I had Windows 7. Make sure your Windows login username is the same as the Mybooklive username setup in the dashboard. Once both are the same, you should be able to map the shared Mybooklive folder again. When using the Map Network Drive folder function in Windows 10’s explorer, DON’T click Browse. You have to manually type in the share’s name into Folder field. For Example, I had to type in \MannyNAS\Mannys_Techfiles. After this, Windows 10 explorer shows my shared folders and contents as I mapped them. Goodluck.