Connection with windows 10 newest update

Dear forum guests,

I have a Western Digital My Book Live NAS that is around 8 years old.
Its “worked” problem-free with Windows 7 all these years
From the end of December 2019 a new PC with Windows 10 with al new updates installed.
From that time on I have problems accessing the WD My Book Live disk.
Disk is wired with internet cable connected and included in the network.
Share and stream in activated in network settings.
With windows explorer looking at network, on the left in the explorer, I don’t see the disk listed. On the right side sometimes it shows sometimes not. And sometimes its mentioned as Twonky, can approach it and see what it says but not upload or delete anything.
On the WD disk there are shares including share public where everything, music, video and files are stored. With a shortcut on the desktop I was able to open the My Book Live and “edit” it before, also in the beginning with windows 10. Not anymore. I have come to know that Windows 10 no longer has a workgroup in the network and that excessive security measures are likely to cause this problem.

I have googled a long time already and applied various solutions such as register tweak Lanmann guest,
SMB 1 checked, different windows services automatically set to eg DHCP, DNS client UPnp device host etc. The strange thing is that it was accessible one time but now it is no longer.
I have not yet tried system recovery.
All in all a whole story, hoping that anyone of you can help me

Kind regards,

Willem-Jan

One moment the NAS, My Book Live, can be seen in the network (photo 1) and I can also “get in” here. A moment after when I have restarted the PC, the My Book Live, assigned as disk Z, is not visible. . (photo 2)
Strangely, it cannot find itself.

I have the same issue with the drive not being seen in Windows 10 Pro. I have done all of the installing of SMBs and services and at one point I could see the drive for about 2 weeks and with another update to Windows I no longer can see the drives. The shortcuts that I had previously created still work but I no longer see the shares in the network. I too am looking for help with all of these Windows updates stopping me from seeing my drives. I have three that work great EXCEPT in Windows 10.

“Seeing” and “accessing” the drives are two very different things. Having the drives appear in Window’s Network display has been flaky for many years (although it has been stable for me in the past 3 or 4 months).

You can always access a drive by specifying it’s UNC path in File Explorer. If you want, you can then map the drive and create a new shortcut to it. (There is probably a way to create a shortcut using the UNC path but I haven’t tried that.