How to access MyBookLive via Windows 10.0 Explorer?

Hello,

I’m looking to access MyBook through Windows Explorer. Right now I can only access the files through the WD MyCloud App on my 2nd PC.

I’m using Windows 10. One my 1st PC, I can access MyBook through Explorer. However, the 2nd machine cannot access MyBook. Are there specific settings that I’m missing? Right now, if I click on the icon in Network, it takes me to the MyBook settings webpage.

Hi,

If you are within the same network, you will need to map the drive on all the PC’s.

See if the following link helps: http://support.wdc.com/KnowledgeBase/answer.aspx?ID=2676

Thank you, but that didn’t work.

MyBook is not showing up under the network so I can’t map to it. The only way I can access the drive right now is through the weblink.

where it says folder you can try either
wdmycloud\public or the ip address
192.168.1.1xx\public

Thanks, but that does not work. I need to access the drive THROUGH Windows Explorer. No idea why I can do it on one machine and not the other. Are there settings I’m missing? Thanks.

Is there anyone that can help? I’ve been trying to get this fixed for two days now. :confused:

try this \\wdmycloud\public

I’m just going to return this drive. I’ve followed the steps to get help and this is still not working. Maybe WD should rethink sending people to the forums for help.

If I click on the MyBookLive icon, it takes me to a webpage for the device. This isn’t what I want. I need to access it via Windows Explorer like the (now) other 2 machines. I don’t understand why this ONE machine cannot access that same drive through Windows Explorer!

I’m having the same problem after a recent Windows 10 update. The drive is no longer showing up as a PC on the network.
You can open your files in Explorer by right-clicking the MyBookLive > open. This will open your directories in a new Explorer window.

1 Like

Thanks Brian, this dolved my problem

the problem is: “open” didn’t show up when we right-click MyBookLive… that’s Kerri’s problem (and my problem too). :blush:

accidentally, my problem’s solved. I guess this happened because of windows 10 update.

Did you know how was your problem solved? Please share if you do, thanks. I have exactly same issue, two laptops running same Windows 10, one has the MyBookLive in “Network > Storage” section, double-click will open it by web browser and can change settings, the other has it in “Network > computer” section, double-click will open it by Windows Explorer, can access all folders.
I am disappointed the conversation stopped without a solution. Hope someone can point out what to do - I need to have assess to settings and contents using the same computer, not two. :frowning:

I just updated my Windows 10… and all were solved automatically…