Neither MyBookLive nor WD MyCloud appear in File Explorer listing

System is a Windows 10 platform on a Dell XPS.

First noticed last evening that the File Explorer listings (under Network) for the MyBookLive and WDMyCloud drives are no longer being displayed. Obviously, this makes it a difficult task to access resources stored on these devices. There were NO OTHER CHANGES made to the entire system.

If more details are needed, please inquire and I will respond.

Thank you in advance.

Would this link help?

1 Like

sleepyhong, thanks for the reply. This does not solve the issue. BOTH of the WD devices’ names are set in uppercase via the Web interfaces. Their appearance on a given computer’s Explorer window is random, but consistent on a particular computer. I have attached a screen shot which I hope will assist in diagnosing the cause of the issue. Thanks, again!

1 Like

There seems to be a problem in Win10 - reported on several Windows fora but not yet addressed by Microsoft - involving discovery of remote non-Windows devices. I have 2 MyBookLive NAS drives, one MyCloud, and on Synology DS218. The 3 WD devices show up for a while after a reboot of my primary computer but eventually disappear from File Explorer. The Synology drive never appears on my primary computer but sometimes shortly appears on a less used computer.

Shares on all of these devices can be accessed either by mapping the share or by specifying the the drive name or address to File explorer. Windows has no trouble accessing the drives or the shares they contain. It just has trouble displaying them in File Explorer.

1 Like

Hi John,

I noticed that your 2 storage are named: MyBookLive and WDMyCloud. They are not all uppercaps.

You may want to attempt to change one of it, e.g. MyBookLive to MYBOOKLIVE. It is located in the settings in the device login page. I changed mine from CloudyHong to CLOUDYHONG and it appeared immediately in my Computer list.

Give it a shot. You have nothing to lose. :slight_smile:

I created an account here because I’ve been fighting with this same issue for three days and I finally found the solution. I’ve tried all caps, I’ve tried all different settings, I did finally get \mybooklive to show up in the networking options, though for the life of me, I can’t remember which of the many solutions got that. However, I was still getting the error that it couldn’t see the network path. I then happened across this “feature” that’s been added to windows. Apparently the drive is looking for a guest login, and by disabling this it now has no problem seeing the drive through the File Explorer.

I realize this isn’t the most secure solution, but maybe it will help WD figure out how to fix the issue on their side.