Trying to use TimeMachine backup on My Cloud for dead Mac


My iMac is showing a No Entry sign at start up so I need to restore the OS from my TimeMachine backup on a WD My Cloud.

I’m getting as far as the My Cloud requiring login but either I’ve forgotten the name and password or it refuses to acknowledge them - probably the former!

It is asking for a “Name” and “Password”. It automatically fills in “System Administrator” and leaves the password field blank. I have tried my WD-registered email address, admin/admin, left password blank, tried my name with and without spaces and upper-case letters. But no joy.

I reset my dashboard password, and I can get into the dashboard, but have no idea how I can encourage the iMac to accept that it’s me accessing the My Cloud.

Any ideas?
Thanks! Simon


I had a similar problem some time back, what I had to do is login with my main user/pass from the WD dashboard.

Also, if one didn’t have a password set to access the WD dashboard, time machine would not start the backup!

Thanks. How can I log into the dashboard to check this? I can log into the My Cloud page that shows Files and Shared. Is this the dashboard?

I have changed my password but think I need to change the “storage device” password.

Any idea how I do that?

No. The Dashboard is accessed while connected to the same local network as the My Cloud and is typically accessed, if one hasn’t changed the My Cloud name, via: http://wdmycloud

Or see the My Cloud User Manual, Chapter 5, The Dashboard At a Glance, for how to access the Dashboard:

The Dashboard looks similar to this:


My main Mac is not working, hence my need to access the backup source (on My Cloud).

When I try to access the dashboard on a laptop (MacBook Air) do I need to physically connect via Ethernet to be on the same network as the My Cloud, or can this be done wirelessly?

I’m pulling what’s left of my hair our because I have everything I need to get my iMac working again but it’s this darn name and password that is stopping me use my back up.

If I can somehow get onto the My Cloud dashboard then maybe I can work out the password or even what it thinks is my user name.

When I try my computer’s admin name and password, it states that “There was a problem connecting to the server “SJMyCloud-Home-2.local”. Check the server name or IP address, and then try again. If you continue to have problems, contact your system administrator.”

By system administrator I presume it means me!

It can be done wirelessly provided the My Cloud is connected to the same local network as the computer your using to access the My Cloud.

[quote=“SIMON_JARY, post:6, topic:162298, full:true”]
When I try my computer’s admin name and password, it states that …[/quote]
To log into the My Cloud you DO NOT use the login name and password you used to log into your computer, rather you use the User and Password you created on the My Cloud when the My Cloud was initially setup. IF one didn’t change the main administrator account and didn’t assign a password when setting up the My Cloud they can try using “admin” for the User and leave the password field blank.

If one forgot the My Cloud administrator account information (and password) one can reset the My Cloud by performing a 4 second reset or 40 second system restore via the reset button on the back of the My Cloud.

Thanks, Bennor.

I’ve tried admin and blank, and no good. I presume I did set up a user name and password, and I’m usually very good at remembering these as I have a system, but the My Cloud has floored me.

When I use my Mac’s admin name and password it gives me the “problem connecting to the server”, which makes me think that might be it but something else is wrong. Typical!

I’ll try the reset. Do I then just go for admin and blank?

Just a heads up!

As I said earlier, you need to have set a password or TimeMachine will not let you restore the backup! without a password being set for the User"

Thanks, everyone. Nothing’s working, so I need to find another (non My Cloud) disk with an older backup on it and hope that doesn’t require a password I don’t know.
Otherwise I’ll have to pay a pro to take the thing apart.