True Image Will NOT Install even with My Cloud Mirror, San Disk, WD Drive

I have just downloaded the WD Version of True Image but it will not install and run. I have an HGST, San Disk and a WD 3.5" all being part of the system at some time each with an attempt to load and run True Image. I really need this to work so that I can get a fast SSD drive into a slow 4GB HP nightmare system. The Seagate version will not do GPT so I have to use the WD version Acronis is trying hard to sell their product and I will NOT buy something that I have qualified for free.

Which particular hard drive model would the WD 3.5" unit be? Is it connected internally? Is it part of a RAID or connected to a RAID controller?

Hello to Trancer any others who might venture to comment. I have a WD Purple attached via USB Thermaltake with a San Disk 240GB SSD and the 2.5" HGST 750GB as the present system disk. I have even directly tied in my My Cloud Mirror using the direct ethernet connect to be sure that there was plenty WD signatures all over the place so it would not fail. There is only one option that is not open to dialogue; buying a package from Acronis. I made the software install on my server without connecting the My Cloud or the HGST.

As stated, any help is greatly appreciated. I am using this in my international knowledge network, totally legit and no hacking.


And this is the root of the problem. None of those drives will allow you to install Acronis True Image WD Edition. It requires a direct, internal SATA connection, and some USB enclosures can interfere with the program’s signature validation.

The Support page for the application lists the following hard drives as eligible:

My Book, My Book Duo, My Passport, My Passport Ultra (WD Backup), My Passport Ultra Metal, WD Blue SSD, WD Green SSD, WD Blue, WD Blue (Mobile), WD Black, WD Black (Mobile), WD Gold, WD RE / WD RE4, WD Re+, WD Se, WD Red, WD Red (Mobile), WD Red Pro, WD AV, WD Blue SSHD, WD Black SSHD, WD Desktop Performance, WD Desktop Mainstream , WD Network, WD Laptop Mainstream , WD S25.

Thanks Trancer,

This makes sense, I will use the San Disk SSD Without the Thermaltake to see if that allows the WD True Image to initiate. I am in SE Asia and the WD personnel here do not understand how to make complete statements that have English knowledge in it. I can immediately read and understand your complete statements.

I truly appreciate your rational answer though I think that WD needs to change that list, I am using an HGST hard drive as the internal drive and that is now, like San Disk, a WD brand. I do not like to let my emotions get into the matter but I do like WD and I do not have the greatest regards for Acronis. I will try the solution this morning of adding the San Disk with a SATA bridge or direct USB 3.0 connector to see if it allows a valid connect. I will let you know how it goes and hope that this helps others. I love sharing knowledge and look forward to other exchanges. I use the WD My Cloud Mirror as my medium for exchange with good people over the world, nothing illicit or illegitimate, just good knowledge sharing. I will replace the 2 2TB units in the My Cloud this year with a couple of 8s. I have a Seagate 8TB that is offline to the world as my private vault.

Thanks so much, I owe you one!

I tried the direct connect using a Seagate USB 3.0 portable adapter and Acronis said no so I looked at what was in Device Manager and sure enough, it does not show anything but the HGST drive and a Seagate controller, not the San Disk. Now, I will try the HGST USB adapter. I am on top of this and will try things as soon as they come in until I solve the problem.

Thanks again,

Hi again,

Some success, the HGST USB 3.0 controller does report the actual drive that is in the case so I have to disassemble the unit, place the San Disk on the controller and that should do the trick.
Thanks again,

Hello Trancer and all,

As you can read, I am really hopping on this and sadly, that list that you present above may be the culprit but it does not reference the San Disk SSDs and those devices are specifically stated in other documentation as eligible devices. I have to sadly report to you that even the San Disks do not do the job, as you can see on the attached jpg, the San Disk is reported in the Device Manager so it should be accepted.

I think that this proves conclusively that a WD sanctioned product is in the mix so it should be working. I get nothing but double talk from the people here in SE Asia so I ask that someone in the US or other places send this to WD US to help resolve the problem. I am including some nonsensical reply that I got from a guy here to address the problem.
"I’m from Western Digital Technical Support team and I have received this case as an escalation.

I have tried to call you earlier but it seems you were not available.

I would like to confirm that you have a concern regarding with the Acronis True Image WD Edition to be use on a HGST Internal drive, a San Disk SSD to be cloned to, and a My Cloud Mirror or WD Purple in the system?

We hope that we were able to address your inquiry to your satisfaction and we appreciate the time you taken to contact us. Should you need assistance and/or have any further inquiries, please do not hesitate to contact us."

This person person did not try to call me as I have no listed phone number and there is a trap on my phone to register/record every call that comes in. He states “I would like to confirm that you have a concern …”. I do not have a concern, I have a problem and double talk does not address that problem. The woman ahead of him was worse, if that is possible.

WD SUPPORT, I need your help here!

Does anyone know if WD is going to add the new hardware that it has recently purchased to the list of supported by True Image software?


I want to pay some homage to Trancer, your information was so correct! WD does not currently support its new purchased products; San Disk and HGST. I really hope that they change that soon. Trancer told me that the Thermaltake was hiding the IDs of the San Disk and the Purple WD and that was the problem. The Acronis software does support the WD purple as that is what got the software to run in my server. I do not have a WD 2.5" internal HD and I am not buying one just for this and Not buying a WD drive that I cannot use just to get True Image to work.


SOLVED: Version 33 works with San DisksI do hope that others can use this information helps others, Acronis True Image WD Edition available from WD at will recognize San Disk SSD drives. It must see a WD or San Disk for the complete operation to clone. There are some scary parts of the process, I am in the middle of doing it now so read my other posts to get the full scoop.

The clone of my HGST hard drive boot system and all partitions went well. The old hard disk was rendered not bootable at first but playing with it using the rescue and letting Windows work on it finally paid off, it is now available as a back up. The cloning took a long time to move 380GB of data and then I also added 4GB by taking out 4GB and putting in 2 used sticks from my main system, which is now at 16GB. HP sure stuck it to everybody who buys their new systems with very difficult to open cases and fine plastic/thin film connector cables. You have to take out the mainboard to get to the memory AFTER taking out 14 screws just to get the case open. For those brave souls trying this, there are 2 screws hidden under the rear rubber feet. It will seem like it is no way to get them out but you just have to persevere — delicately, they will come out and then you have the last obstacle out of the way. No More HP! The cloned drive worked great after I reopened the case to put the thin film cable onto it right. All the thin film cables have to be perfect to make it work so be careful. The system was a lazy touch 17" AMD unit before but, now with the SSD and 4 More GB of DRAM, it is a new screamer using the best Win 10 and only 20GB of space taken for the OS.

Gist of this: Use version 33 or later, Use the Rescue Media to get the cloning started if you are using Win 10, it says it is going to do the cloning after you restart, it won’t, you have to tinker with it until it allows you to use the Rescue Media and then it will start the cloning that will take forever but it works. The slow performance and lousy construction makes this unit one that will not get much use but it is now at least 3 times faster.