Troubleshooting, just blame WD

update: I did not intend it to be this way, but this is now a two post troubleshooting and solution. Read this one to get a sense of the anguish and frustration that the collective “WE” of this WD forum go through to troubleshoot their little Cloud device when something goes wrong and all we have is a little black box that blinks it lights at you, then read the other post for the real solution with a Bill_S post replying at the end. Click here for the follow-up post.

Well since I broke my vow of silence, I figure I should post this up.

One thing to note that it is not my intention to show off any level of knowledge that I may claim to posess and as I grow older I know that I know less and am generally wrong so in most of my post I try to cover all the possibilities.

So bear with me as I post up the troubleshooting steps even though the solution is very mundane and probably will go hand in hand with rebooting the Cloud.

So a couple of days ago, after mapping my cloud to my Mac, I had no access to all my files.

Troubleshooting step 1:

Initially I suspected that I had a corrupted MPlayerX on my Mac as each time I started up a movie, safari would lock up showing no internet service and my cloud would disconnect. Repeated this several times, map the Cloud as a local drive, double click on a movie, internet freezes, cloud drops off. Tried other movie players like VLC, same result. SSH locks up and you have to re-logon again.

Troubleshooting step 2:

Tried copying files from Cloud over to my Mac. Cloud disconnects and the copy file remains at 0 bytes. SSH locks up and again you have to re-logon again.

Troubleshooting step 3:

suspected AFP, so I restarted samba and reconnected via Samba. Same result except the Cloud did not get disconnectted, just locked until an error message pops up that the file could not be copied. Mapping remains and I could go into sub-directories.

Troubleshooting step 4:

Suspected Remote access related to WD. actually signed on through cloud app and was able to play movies and access files. Stopped remote and even killed OpenVPN. Surprisingly when a movie is clicked on, it takes about 20 seconds to start up but the movie started playing on my mac. 

ok… what seems to stop or slow down access to my Cloud. My cloud seems to be alive via SSH and file permissions seems to be ok via cloud access and through SMB movie player.

So I thought… reboot my router… 


Now the interesting thing after rebooting my router when I connect to my Cloud now via AFP:, the login panel pops up immediately, before the router reboot the login panel would take about 5 to 10 seconds like it was waiting for the cloud to wake up. 

After logging in, the directory listing was also immediate. it was like I had a newer faster Cloud. No my cloud did not get autoupdated as I am still on 3.04 firmware.

The two things that I did do was to turn off cloud access and killed openvpn. I did restart my cloud access as well as restarted openvpn (the service is started but OpenVPN is not running when checking with ps -ALL).

Yes this is a long winded, do nothing post and if anyone managed to read it you can take away the knowledge of

“Reset your Router” 

k… I’m done… back to my lurking…

1 Like

It’s usually a good idea to try different procedural steps when troubleshooting in order to isolate an issue. 

1 Like

I reboot all (4) of my routers every few days.  It is my experience over many years that most consumer grade routers have poorly managed routing tables and they get too long and outdated quickly making routine network traffic slower as each hour/day goes by.

So, yes, reboot those routers when you are seeing a slower response to traffic and the dashboard.


1 Like

I’m a complete newbie to MYcloud , been playing around trying to get it to work (mainly problems with images not showing) The solution that has worked for Me is t do a System only restore.

I think Ralphael may have been making a more general point …

Microsoft launch a new OS that doesn’t work with MyCloud: blame WD.

Apple release an update to their OS that doesn’t work with MyCloud: blame WD.

Apple change their iTunes API without making the details public, so iTunes no longer works with MyCloud: blame WD.

Smart TV media player doesn’t support certain file types over DLNA: blame WD.

Poor router software gives declining performance: blame WD.

External USB HDD PSU faulty: blame MyCloud.

Didn’t read the User Manual: blame WD.


WD have enough problems with the MyCloud. But let’s only blame them for the things they are actually responsible for…


Well said cpt_paranoia

1 Like