Symptoms of a Cloud going bad: Blame WD

So I just spent the last few hours pulling hairs thinking that my Cloud was on the brink of going bad. I thought that if it does go bad that I will switch over to QNap!! (sorry WD after four years of unknowns there is no loyalty left unless of course I’ve been hinting at getting a free Cloud) :-P 


Same Problem as last week, rebooted the router:

I got the same problem as last week as I tried to access a file which crashes both the Internet and boots the cloud off my Mac.

No internet browsing on safari and the mapping of the Cloud would disappear (mounted via AFP).

same troubleshooting, except this time I rebooted the router first expecting everything to be fixed.

Nope. Now it could be a broken router that the pathways are corrupted; however my home system is so simple as I only have the Mac and Cloud attached to the router. PC is off and has been off for over a month now.

It was a dark and not rainy night"

It all began after my other beloved device iPhone ran out of cloud space for backup and I’m too cheap to spend 99 cents to upgrade to 50GB); I insist on using the default 5GB that was given to me.

So I started to backup my photos using OneDrive (it doesn’t mess with the dates :-P). 

and then I accidentally used the cloud to back up my ipad of 29 photos which resulted in the problem.

Was going to view my ipad photos on my Cloud and when I clicked on one of my photo and

The little cursor ball started spinning,

the cloud ejected

the internet showed no internet connection. 

WIFI (iphone, ipad is ok)

rebooting the router did not resolve the problem

So now what? 

I mounted as SMB instead of AFP

I stopped the openvpn services (WD openvpn is changing the ownership of my files)

I turned off remote access (thinking it has to be WD fault)

I thought it might be ownership… used chown to change ownership, and chmod to change file attributes. 

I created a new folder and copied all the files over to the new folder and also changed ownership.

I started testing movie files and to my horror, some movie files played and some didn’t. The ones that didn’t, caused a massive lock on the Cloud and internet (little spinning cursor ball).

I rebooted my Cloud

So I got random movie files all over my hard drive that some played, some didn’t. 

OK, so my Cloud drive is failing… 

So I mounted my USB drive which is attached to the Cloud expecting all the files to be okay… (it is almost a mirror of the cloud).

Same movie file, same location…  it doesn’t play? and cannot copy to the mac

yes… I have rebooted the router many times now and that is the only common theme between my Mac and the Cloud/USB My Book.

Both the Cloud and the My Book shows exactly the same symptoms… which is some files cannot copy or play as a movie.

The ones that do play, will show up a spinning wheel for 5 or 10 seconds before playing.

I really hate WD… **bleep** black linux box… grumble…

When I had a PC server, I never had one problem; not even a sleep problem.

The Solution

Now there is one item that I suspected but I kept thinking that it is unrelated.

I am wiht Shaw and Shaw’s DNS is absolutely terrible. Not always, but most of the time. So I changed my Mac DNS to Open DNS or sometimes I would use Google DNS.

My Cloud uses Shaw DNS servers since it doesn’t really have any domain names to resolve (so I thought).

I changed my Cloud Static IP DNS servers to Open DNS to match my Mac.

That was the solution.

Alright… so why would mis-match DNS servers on a local network cause the copying, opening or launching a movie file viewer to lock up the network?

second question: This configuration has been this way for over 8 months, so why now?

third question: is this related to the WD remote servers being takened off line?

hmmmm… it started happening when the WD servers went offline… so it is WD fault!! It has to be :stuck_out_tongue:

Update: So I started up my PC; no it is not an old beat up IBM 386 :stuck_out_tongue: I was a very serious PC user before I became a Jedi with Apple :stuck_out_tongue: This PC was built for gaming. 

Anyways, the PC still has DNS server pointing to Shaw’s DNS and the Cloud has its DNS servers pointed to Open DNS. I’ve mapped the cloud and the USB my Book to X: and Z: respectively and have been copying, deleting, moving files without a single hint of trouble.

Thus the problem only occurs with the Mac. 

I know this info is going to get lost in this forum, but for whomever reading this… please pass it on.

It is serious because it will look like the Cloud has gone bad.

  1. Files cannot be read,

  2. the cloud will eject or unmount itself

  3. if the file does get read, it is really slow in starting…

And here is the thing… it doesn’t occur constantly… as I had rebooted the router last week and it worked afterwards. 

I think only when the DNS servers are slightly out of sync?  or even worse is that it may not be the DNS servers afterall and it may be a problem with the Cloud?

Let me know what your thoughts are?

Alright, so I think I figure it all out as I did a search on the Net for this potential problem and found nothing.

Nobody else in the world would have this problem (unless they did what I did), this is why when I searched the Net for a solution there wasn’t any…

I  would have just left this post as it is to let everyone think that a different DNS is the problem but that is not the main reason of what happen; it is and it isn’t.

So instead of saying it is my fault, lets start off with why this even occured.

The question is Why do I have two different DNS servers on two static IP (Mac and Cloud)?

Shaw is my ISP in Vancouver and everything in my house was originally set to Shaw’s configuration which included Shaw’s DNS servers.

Thus for the Cloud static IP, I copied everything over from the router including the DNS numbers. 

Same for my Mac and my PC; both are static so I can use remote desktop.

Once in awhile Shaw’s DNS servers would freeze trying to resolve a URL. I would notice this problem quite often as I type in a URL or click on link, it would take umpteen seconds to resolve. So one day I decided to google this problem and voila, everyone says to use Google DNS or Open DNS.

On the Mac I can make multiple network config files and change my settings on the fly; thus some days I would use Shaw DNS (because the other DNS servers may be overloaded since everyone is using them) and some days I may flip between Google DNS and Open DNS.

Meanwhile my Cloud had kept its original Shaw DNS settings. 

Thus if Shaw is working and I’m using Google DNS on my Mac, I won’t notice any difference.

However, if Shaw DNS Servers goes down and Google DNS did not, I would probably experience what I just experience.

My Cloud would go down because it would try to send the file packet to a DNS address, even though it might be a local IP, it probably uses the DNS servers to route it or resolve it, the packet gets lost.

The Mac waits for it, which gives the symptoms of locking. Also my Safari would lose its internet because there is a clash of DNS servers (I’m just guessing at this point with no clue of what I’m talking about). 

Thus my Mac drops the cloud thinking it is now offline. The lock is unlocked because it no longer waits for the packet.

The first time that I reset my router, the Shaw DNS servers came back up; thus everything worked. 

The reason that I did not encounter this problem for the last 8 months is probably due to luck. I don’t connect to my Cloud as often as I did last year, so when I do, Shaw DNS is up and running.

On the occasions that Shaw DNS servers went down, I might have been on Shaw’s DNS servers on the Mac too which then I would attribute as Shaw is down.

Recently I’ve been using OpenDNS servers more often and inevitably this clash of two DNS server finally caught up to me. Of course my PC did not have any problems today because Shaw is up.

However now that my Cloud is on OpenDNS servers, I would doubt that I would ever see this problem again. (knock on wood).

So there you have it… another useless post from Ralphael. 

Your take-away… if your cloud won’t serve your files, check your DNS servers and then go write a long post on WD forums on how bad the Cloud device is. 

Thanks for reading…

Wait so WD isn’t blame? What heresy is this? You know its always WD fault even though someone didn’t read the manual, was having a DNS problem on their end, modified the My Cloud OS, or was some other factor beyond WD’s control.


< Note: The preceding was sarcastic/satirical in nature, none of the preceding bytes should be taken seriously, no bytes where harmed in this posting - :slight_smile: >

1 Like

I blame WD for being locked on this forum :frowning: my life has been consumed with debugging ever since I bought the WD live.

Here have a few kudos, you need to catch up to cpt_paranoia :stuck_out_tongue:

I know it’s no consolation for any of the other issues you’ve encountered, but thanks for you honesty, Raphael.  

1 Like

Bill_S wrote:

I know it’s no consolation for any of the other issues you’ve encountered, but thanks for you honesty, Raphael.  

a toast to your new OS that will solve all our problems… right Bill_S?




haha…  smart aleck…,