Trouble setting up My Cloud EX2 Ultra

I am sure that it has been discussed many many times on this forum and i did tried a few of the solutions mentioned but failed to detect my cloud.

already did a 5 sec and 40 sec reset.
the power light is solid blue (after some time it pulsates probably because it goes in standby mode)
my hard disk light is solid red since I haven’t set up my hard disk even once.

please let me know any information that is needed. I need help.

I am uploading a few screenshots in order to describe my problem.

Go into your router’s settings and look for “attached Devices” (or run Advanced IP Scanner). Is your NAS getting an IP address?

Is this a new or used EX2?

My cloud is getting an ip address.

It is brand new… atleast from the packaging i am assuming it is brand new haven’t seen any scuff marks and it was well sealed in plastic.

Brought it from Amazon so can’t be too sure about it.

Remove the hard disk. Partition it and format it and then reinstall it in the EX2. You don’t need 2 drives in the EX2 but make sure its in bay 1.

which format should I format it in?
fat32 or some other format?

read somewhere that NTFS is not good for EX2 Ultra. is it true?

Id try NTFS first. If thst doesnt work, try ex-FAT.

nope it didn’t work
the light is still solid red and when i try to enter the ip address of my cloud ex2 ultra it says connection refused to connect

Did the drive partition and format outside the EX2? If not, it’s a bad drive.

yes it did…i partitioned it outside the ex2…i connected it in a pc and did an ntfs format and made a partition…all well

Not sure what to tell you at this point. The drive is good, the system is on the EX2 (not the drive) so it looks like a defective EX2. Return it to amazon for a refund.

that is what I am guessing.
:disappointed: no return just replacement option available.
have already placed a replacement order hope the next one won’t give me this problem

It shouldn’t. I bought a bare EX2 and a bare MyCloud Mirror (basically the same) way back when and had no issues with new or old drives.

one more thing i need to confirm is that drive compatibility issue.
i brought segate baracuda 4tb internal drive. is that the problem here?

I don’t think so. WD only specify WD drives as “tested” for compatibility. I’ve used seagates and hitachi’s in both my systems with no problems.

Something that might interest you… I just tried to connect to my EX2 using the mycloud setup app - no can do. I get the same messages you do. I can access the dashboard through it’s IP address and the content through Advance IP Scanner but not the mycloud setup app. Make of that what you will.

I think you might still have a problem but I’m not sure how you’re going to set up a new mycloud when the app doesn’t appear to be working.

Thanks for all the help and replies you gave. I really appreciate it. was not expecting someone to help me out on the forum but a humble thanks to you again.

Turns out the device was defective all along. Received a new device today and it begin working in couple of mins only.

as i have spent few bucks on this now and don’t see anyone buying this from me so stuck with it for a while. Will switch over to Synology if it gives me more trouble.

Hi Mate

Hoping you get this. I’m having the exact same problem as you with my new EX2 Ultra, except now when I try to enter the setup page it just doesn’t load.

How did you figure out your product was faulty? Did you get in touch with WD or with Amazon?

Disable your adblock and the pages will appear fine.

sorry it has been long time and i suppose you must have had found a solution to your probem but i had order my EX2 Ultra from amazon and i simply raised a ticket for product replacement. when i recieved the new one it was working fine.